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I Introduction to R-Linux

R-Linux is a file recover utility for the Ext2/3/4FS file system used in the Linux OS and several Unixes. R-
Linux uses unique IntelligentScan technology and flexible parameter settings to give you real control over
the fastest data recovery ever seen. It recovers files from existing partitions even when file records are lost.

R-Linux is a lite version of more powerful file recover utility R-Studio. R-Studio utilizes the IntelligentScan
technology to its full extent, and therefore can recover data from partitions with broken file systems. Also, R-
Studio recovers data over network. To learn more about R-Studio, go to the R-Studio Features help page.
To learn more about the IntelligentScan technology, go to the IntelligentScan help page.

R-Linux features:

· Standard "Windows Explorer" - style interface.
· Host OS: Linux, kernel 2.6 and above
· Supported file systems: Ext2/3/4FS (created by Linux or other OS).
· Support for known file types. R-Linux searches for files with known typical features of their structures

allowing the user to search for files on devices with unknown files systems, including an HD, CD, DVD,
floppy disk, Compact Flash Card, USB drive, ZIP drive, Memory Sticks, and other removable media.

· Scan process visualization. While scanning an object, R-Linux graphically shows items that have been
found,.

· Creates image files for an entire hard drive, partition, or its part. Such image files can be processed like
regular disks. Images can be either simple exact object copies (Plain images) compatible with the previous
versions of R-Linux, or compressed images that can be compressed, split into several parts, and
password-protected. Such images are fully compatible with the images created by R-Drive Image, but
incompatible with the previous versions of R-Linux. R-Linux can scan objects while creating their
images.

· Recovers files on damaged or deleted partitions.
· Support for estimation of chances for successful recovery.
· Recovered files can be saved on any (including network) disks visible by the host operating system.
· Support for Linux mdadm Volumes
· Support for Linux LVM/LVM2
· A hexadecimal disk and file viewer.
· Patterns (or templates) in the hexadecimal viewer allowing for parsing the data according to specific data

structure. Such patterns may be custom-created.

R-Linux recovers files:

· Removed by virus attack or power failure;
· After the partition with the files was reformatted, even for a different file system;
· When the partition structure on a hard drive was changed or damaged. In this case, R-Linux can scan

the drive trying to find previously existed partitions and recover files from found partitions.
· From disks with bad sectors. In this case, R-Linux can first copy the entire disk or its part into an image

file and then process such image file.

R-Linux can create image files for an entire hard drive, partition, or its part. Such image files can be
processed like regular disks. Images are very useful if there is a risk of total data loss due to hardware
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malfunction. If bad blocks are constantly appearing on a hard drive, the only way to save the data is to
immediately create an image of that drive. All data search, scan and recovery can be done from this image.

R-Studio Features
System Requirements
Contact Information and Technical Support
Data Recovery Using R-Linux
Basic File Recovery
Advanced Data Recovery
Mass File Recovery
Text/Hexadecimal Viewer
Technical Information and Troubleshooting

1.1 R-Studio Features
R-Studio is a family of file restoring utilities. It recovers files both on local disks and on disks on remote
computers over network, even if their partition structures are damaged. A unique IntelligentScan technology
and flexible parameter settings give you real control over the fastest data recovery ever seen.

R-Studio for Linux features:

· Host OS: Linux, kernel 2.6 and above.
· Automatic check for updates.
· Remotely recovers data over network. Data can be recovered on network computers running Windows,

Mac, and Linux and some other UNIX OS. 
· Supported file systems:

Windows: FAT12/16/32, exFAT, NTFS, NTFS5, ReFS/ReFS2+ file (Resilient File System); ReFS for
Windows Server 2019 (including deduplication).

macOS: HFS, HFS+, HFSX, APFS, FAT/exFAT;
Linux and UNIX: Ext2/3/4FS and XFS (created by Linux or other OS), and UFS1, UFS2, UFS

BigEndian (used by the FreeBSD, OpenBSD, and NetBSD operating systems);
CD/DVD/Images: ISO9660;
Magnetic tape devices: UStar/Tar/CPIO/Pax (R-Studio Technician/T80+).
Please note, that when a file is being deleted on the HFS, HFS+, HFSX file systems, the computer
completely removes all system information on it, and there is no way to recover the deleted file except by
using the Extra Search for Known File Types option. Nevertheless, R-Studio for Linux is able to read
existing files from HFS, HFS+, and HFSX disks.

· Support for known file types. R-Studio for Linux searches for files with known typical features of their
structures allowing the user to search for files on devices with unknown files systems, including an HD,
CD, DVD, floppy disk, Compact Flash Card, USB drive, ZIP drive, Memory Sticks, and other
removable media.

· Scan process visualization. While scanning an object, R-Studio for Linux graphically shows items that
have been found, including files of known types, FAT and NTFS MFT records, boot records, etc.

· Mass file recovery support.
· Support for estimation of chances for successful recovery.
· Support for file recovery lists - lists of files that can be exported from R-Studio for Linux, manually

edited, and then loaded back. Files from such lists will be automatically marked for recovery.

https://www.r-studio.com/What-is-a-File-System.html
https://www.r-studio.com/What-is-ExFAT.html
https://www.r-studio.com/What-is-FAT.html
https://www.r-studio.com/What-is-ExtFS.html
https://www.r-studio.com/What-is-XFS.html
https://www.r-studio.com/What-is-UFS.html
https://www.r-studio.com/What-is-UFS.html
https://www.r-studio.com/What-is-Raw-File-Recovery.html
https://www.R-Studio.com/What-is-drive-scan.html
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· APM, Basic and GPT support. R-Studio for Linux supports all three partition schemes used to define
the low-level organization of data on disks formatted for use with Macintosh computers.

· Support for Linux mdadm Volumes
· Support for Linux LVM/LVM2
· Dynamic disk support.
· Software RAID, volume set, and stripe set support. Support for RAID 6, RAID 5, and RAID 4 layouts.

Support for custom RAID layouts. Parameters like block size and order, offsets, and even the number of
stripe blocks can be explicitly specified. Custom RAID configurations can be saved.

· Support for Windows Storage Spaces, created by Windows 8/8.1 and Windows 10/Threshold
2/Anniversary/Fall Creators updates.

· Support for Apple software RAIDs
· Support for Apple CoreStorage/FileVault/Fusion Drive Volumes
· Support for Intel Software RAID.
· Hardware RAID, volume set, and stripe set support.
· RAID consistency check (check for valid data parity values).
· Automatic RAID parameter recognition.
· Creates image files for an entire drive, logical disk, or its part. Such image files can be processed like

regular drives. In addition to simple exact object copies (Plain images) and R-Drive Image compatible
images. It can create other disk image and virtual disk formats, together with opening several file formats
"read-only". Images may be saved either on the local or remote computer. Image creation can be stopped
and then resumed. R-Studio for Linux can scan objects while creating their images. R-Studio
Technician/T80+ supports multi-pass and runtime imaging. Images can be mounted in the operating
system as devices which makes their content accessible to any program including any other data recovery
software.

· Recovers files on damaged or deleted partitions.
· Recovers compressed files (NTFS, NTFS5).
· Recovers encrypted files (NTFS5).
· Recovers alternative data streams (NTFS, NTFS5).
· Support for NTFS deduplication, including Windows Server 2022.
· Support for file system journal on the HFS+ and Ext3/4fs file systems.
· Support for soft updates journal on the UFS file system.
· Support for extended attributes on the HFS+, Ext3/4fs, XFS, and UFS file systems.
· Support for compressed files on the HFS+ file system.
· Recognizes localized names.
· Recovered files can be saved on any (including network) disks visible to the host operating system.
· A hexadecimal disk and file viewer/editor supporting NTFS file non-resident attribute editing. Data

alteration is available on the Technician/T80+ and Corporate versions only..
· Patterns (or templates) in the hexadecimal editor allowing for parsing the data according to specific data

structure. Such patterns may be custom-created.
· File preview. Most of the file types can be previewed to estimate recovery chances.
· Enhanced remote host scanning procedure. In the new R-Studio for Linux network versions, data are

analyzed on the remote host rather than on the home host, thereby the speed of recovery procedure
greatly increases.

https://www.r-studio.com/What-is-disk-format.html
https://www.r-studio.com/Linux_Help/working_with_windows_storage_s.html
https://www.r-studio.com/Linux_Help/mac_raids.html
https://www.r-studio.com/Linux_Help/apple-core-storage-volumes.html
https://www.r-studio.com/What-is-Disk-Image.html
https://www.r-studio.com/What-is-Logical-Disk.html
http://www.drive-image.com/
https://www.r-studio.com/Linux_Help/multipass-imaging.html
https://www.r-studio.com/Linux_Help/runtime-imaging.html
https://www.r-studio.com/What-are-alternate-data-streams.html
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· Recovered files may be saved on a disk on a connected remote computer rather than be transferred over
network to the local one. Saving recovered files on a remote computer may be useful when the remote
computer has a healthy disk because you do not have to transfer files over network. It may be an external
USB hard drive, for example.

· Support for S.M.A.R.T. (Self-Monitoring, Analysis and Reporting Technology) attribute monitoring.
· R-Studio Emergency*. The R-Studio for Linux Emergency version starts from a floppy or compact

disk when it is necessary to recover data on a computer, on which OS cannot start up because its system
files are corrupted or deleted.

*The R-Studio Emergency is a part of the R-Studio for Linux software package. When you buy an
R-Studio for Linux single license you may run the R-Studio Emergency or/and install the R-Studio for
Linux Windows version on one PC only and you may not transfer the licensed software to another PC. 

R-Studio features available in the Technician/T80+ versions:

· Magnetic tape devices file system: UStar/Tar/CPIO/Pax.
· Multitasking. Several data recovery tasks can be run simultaneously.
· Additional Recovery Options
· Hidden Devices. Some unnecessary device can be hidden in the Main panel.
· Extended file information 
· Symbolic link recovery options
· Drive Copy Wizard to copy any object in the Drives panel to any other object. In addition to byte to byte

copy of any object visible in the Drives panel, smart copy of partitions and drives is available.
· I/O Monitor and Sector Map files.
· Multi-pass and Runtime imaging
· Reverse RAIDs: A technique that decomposes real drive objects into virtual RAIDs. Then those

components of reverse RAID scan be processed like real objects. They can be viewed, edited, imaged,
copied to physical

· Support for third-party hardware.
· Forensic mode.
· File recovery over Internet.

R-Studio for Linux recovers files:

· That have been removed without the Recycle Bin, or when the Recycle Bin has been emptied;
· Removed by virus attack or power failure;
· After the partition with the files was reformatted, even for a different file system;
· When the partition structure on a hard drive was changed or damaged. In this case, R-Studio for Linux

can scan the drive trying to find previously existed partitions and recover files from found partitions.
· From disks with bad sectors. In this case, R-Studio for Linux can first copy the entire disk or its part

into an image file and then process such image file.

R-Studio for Linux can create image files for an entire hard drive, logical disk, or its part. Such image files
can be processed like regular disks. Images are very useful if there is a risk of total data loss due to hardware
malfunction. If bad blocks are constantly appearing on a hard drive, the only way to save the data is to
immediately create an image of that drive. All data search, scan and recovery can be done from this image.

https://www.r-studio.com/What-is-SMART.html
https://www.r-studio.com/Linux_Help/multitasking.html
https://www.r-studio.com/Linux_Help/additional-recovery-options.html
https://www.r-studio.com/Linux_Help/hidden-devices.html
https://www.r-studio.com/Linux_Help/information-about-a-file.html
https://www.r-studio.com/Linux_Help/symbolic-link-processing.html
https://www.r-studio.com/Linux_Help/object_copy.html
https://www.r-studio.com/Linux_Help/i_o-monit-and-sector-map-files.html
https://www.r-studio.com/Linux_Help/multipass-imaging.html
https://www.r-studio.com/Linux_Help/runtime-imaging.html
https://www.r-studio.com/Linux_Help/reverse_raids.html
https://www.r-studio.com/Linux_Help/working_with_the_third-party_h.html
https://www.r-studio.com/Linux_Help/forensic_mode.html
https://www.r-studio.com/Linux_Help/connecting_over_the_internet.html
https://www.r-studio.com/What-are-Bad-Sectors.html
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To learn more about the IntelligentScan technology, go to the IntelligentScan topic .

1.2 R-Linux System Requirements

· An Intel-compatible x86 or 64-bit platform with 32 MB RAM, a mouse, and enough disk space for
recovered files, image files, etc.

· Linux: Fedora 12+, Ubuntu/Kubuntu 10.4+ , Debian 4.0+ or any kernel 2.6+ Linux distribution capable of
installing .rpm or .deb packages.

· Any Window manager.
· X.Org X server 1.7.6+ installed.
· Root privileges to install and run the program.

1.3 Contact Information and Technical Support
To obtain the latest version of R-Linux, go to:

Product Site: http://www.r-tt.com
Sales Department: sales@r-tt.com

R-Linux Technical Support Team is available 24 hours a day, seven days a week, and has an average
response time less than 4 hours.

Tech. Support: support@r-tt.com
Send your support request to: http://www.r-tt.com/SupportRequest.shtml 

File Recovery FAQ: http://www.r-tt.com/File_Recovery_FAQ.shtml

R-tt Forum: http://forum.r-tt.com

http://www.r-tt.com
mailto:sales@r-tt.com
mailto:support@r-tt.com
http://www.r-tt.com/SupportRequest.shtml
http://www.r-tt.com/File_Recovery_FAQ.shtml
http://forum.r-tt.com
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1.4 R-Linux Main Panel
When R-Linux starts, its main panel appears on the desktop.

R-Linux Main panel

Drives panel:

 can select an object by clicking on it.
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Properties tab:

This tab shows the properties of an object selected on the Drives panel.

Depending on the selected object, information on this
Properties tab may vary.

The Properties tab names and values are described in detail on
the Properties tab topic.

Log window:

S.M.A.R.T. Info for a Hard Drive

 R-Linux shows hard drive S.M.A.R.T. states using their icons. You may copy all S.M.A.R.T. attributes
and paste them into a text editor.

Hard drive S.M.A.R.T. states and icons

Normal: This state indicates
that the hard drive is in good
conditions. 
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Warning: This state indicates
that some small problems with
the disk are possible in the
future, you may work with it
but with cautions and regular
check of these parameters.
Disk imaging is strongly
recommended.

Critical: This state indicates
that the hard drive conditions
are critical and chances of
hardware failure are great.
The best recommendation for
this case is to stop working
with the disk and bring it to
professional data recovery
specialists. You may though
continue to work with the disk
at your own risk, but disk
imaging is very strongly
recommended.

When a hard drive is selected on the  R-Linux main panel, an additional S.M.A.R.T. tab will appear. You may
view the detailed S.M.A.R.T. data of the drive.  
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S.M.A.R.T. (Self-Monitoring, Analysis and Reporting Technology) is a technology widely-used in hard
drives and solid-state devices that monitors their reliability conditions to predict possible hardware failures.

Changing the program language

You may select the language of R-Linux main panel. To do so, select an available language on Change

Language on the Help menu

Panel view options

You may set which panels and bars to enable/disable.
To enable/disable:

Toolbar Select/clear Toolbar on the View menu

Status bar Select/clear Status bar on the View menu

Drive pane Select/clear Device View on the View menu

Properties pane Select/clear Properties View on the View menu

Log panel Select/clear Event Log on the View menu

If you have several tabs in the right pane, you may easily switch to any of the tab by selecting on the View

menu

Properties Tab to view the Properties tab

Scan Information
Tab

to view the Scan Information Tab tab

Parents Tab to view the Parents tab

Properties Select data types in which the data will be represented

Sometimes, there may be a lot of similar objects on the Drives panel. Those may be components of a RAID,
for example. You may turn numerical indexes for such objects to distinguish them better. Those indexes will
appear before the object names on the Drives panel.

To turn the numerical indexes on/off, go to the Device item on the View menu, and select/clear:

Show Physical Drives Indexes to display the indexes only for hard drives
Show All Objects Indexes to display the indexes for all objects on the Drives panel

You may select the units in which object's start and size are displayed

To select the units

1 Select Devices on the View menu

2 Select the units in which you want to see object sizes.

You may select
Show as Bytes
Show as Sectors
Show as Bytes and Sectors

http://en.wikipedia.org/wiki/S.M.A.R.T.
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Depending on the task R-Linux performs, its panel may vary. Those panels are described in appropriate
topics. The Properties tab names and values are described in detail on the Properties tab topic .

Refresh

Click this button to refresh the panels.

Show Files

Click this button to start searching for files on a selected
object.

Scan

Click this button to start scanning a selected
object.

Open Image

Click this button to open a previously created
image.

Create Image

Click this button to create an image of a selected
area.

Create Region

Click this button to create a region on a selected
disk.

Remove

Click this button to delete a selected object on the main
panel.

You may also copy the object's information displayed on the Drives panel. Right-click the object on the
necessary column and select Copy Device/Disk, Copy Label, and so on.

R-Linux has two operation modes:

File search on a partition (including recently found during disk scan).

In this mode, R-Linux analyzes data on the partitions. Then it displays all files which records have been
found in the analyzed tables. Then recently deleted files, which records still remain, can be recovered. If files
have not been found, that means that their records have been deleted. In this case, the disk must be
scanned.

File search supports file masks and regular expressions. Multiple files in different folders can be found and
recovered in one recover session.

R-Linux supports mass file recovery. There is no limit in the number of files that may be recovered during
one session.

File content may be previewed before recovery. 

File or disk binary data can be viewed in the Text/Hexadecimal Viewer. Also can be viewed and changed
all attributes for NTFS files. 

Disk scan, searching for partitions.
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In this mode, R-Linux scans the entire disk or its part. Using a number of statistic and deterministic criteria
known as IntelligentScan technology, it determines existing or existed partitions on the disk, and their file
systems. It is also possible to add new partitions, by setting manually all required parameters.

A disk can be scanned through several successive scans, each with its own parameters. R-Linux
accumulates the information from successive scans and keeps track of changes in the information obtained
from different scans. The information obtained from the disc scan can be stored in a file. It may be loaded
and processed later at any convenient time.

1.5 R-Linux Settings
You may specify some global setting for R-Linux on the Settings dialog box. You may reach it by selecting
Settings on the Tools menu.

Main 

Main dialog box

Main settings

System Options

Auto-refresh Drive Tree If this box is selected, R-Linux automatically refreshes the list of
connected disks. You may disable it if R-Linux experiences
problems with connected devices.

Debug Mode If this check box is selected, R-Linux displays an additional
command Create FS Snapshot on the shortcut menu for an object
with a file system. An FS Snapshot contains system data for the
file system only (file descriptions without file contents). If a
problem appears, this snapshot can be sent to R-Linux technical
support to identify the problem. This option greatly slows R-Linux.
 

Check for update If this box is selected, R-Linux will automatically check for
updates.

User path. Mask presets Specifies a file name and path to the file with file mask presets.i
File Systems 
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File Systems dialog box

File Systems

Default encoding for
Ext2/Ext3/Ext4 volumes

Select the national encoding for the Ext2, Ext3, and Ext4
partitions.

Disable any sorting Select this option if the number of files on the disk is so large that
R-Linux sorts files in selected folders for too long time.

Minimize disk access Select this option if a lot of bad sectors are on the hard drive. R-

Linux will reduce access to internal files in the file system to speed
up the interpretation of file system data.

Show deleted empty folders Select this option if you want to view empty deleted folders.

Log 

Log dialog box

 Log options

Logging

Maximum
messages in the
Event Log

Specifies the maximum number of messages R-Linux will keep in the event log

Save log to file If this check box is selected, R-Linux writes its log into a log file specified in the File

name field.

File name Specifies the file name in which the log will be saved.

Type
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File If this check box is selected, R-Linux logs all events with recovered files.

File System If this check box is selected, R-Linux logs all events with the file system.

Partition If this check box selected, R-Linux logs all events with partitions.

Recover If this check box is selected, R-Linux logs all events with the recovering processes.

Disk If this check box is selected, R-Linux logs all events with disks.

Network If this check box is selected, R-Linux logs all events with network operation.

Severity

Error If this check box is selected, R-Linux adds error messages into its log.

Warning If this check box is selected, R-Linux adds warning messages into its log.

Information If this check box is selected, R-Linux adds information messages into its log.

Success If this check box is selected, R-Linux adds success messages into its log.

NEVER WRITE A LOG FILE ON THE DISK FROM WHICH YOU RECOVER DATA!!!
Or you may obtain unpredictable results and lose all your data.

Note: If in the Recover dialog box the Condense successful restoration events check box is selected,
the Log will display only Error, Warning, and Information event messages.

Known File Types 

Known File Types dialog box

You may specify which Known File Types will be enabled/disabled by default. You may also specify
know file types to search for during a specific scan session on the Scan dialog box.
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Known File Types

Reset Click this button to reset the settings to the previous state. Active until the
Apply button is clicked.

Select All Click this button to select all file types in the list.

Clear All Click this button to clear all file types in the list except some predefined ones.

Reset to
Recommended

Click this button to reset the settings to the recommended set.

Bad Sectors 

Bad Sectors dialog box

Bad Sectors settings

Default read retries count Specifies a default value for I/O Tries, or how many times R-Linux will try
to read a bad sector. You may specify this parameter for each drive
separately on the Properties tab.
R-Linux treats bad sectors in the following way:
It reads a certain part of disk (predefined by Windows) and
· If Default read retries is set to 0, the entire part with bad sectors will be

filled with the specified pattern. 
· If Default read retries is set to a non-zero value, R-Linux reads again that

part sector by sector, repeating the attempts the specified number of
times. If R-Linux still cannot read a bad sector, it fills the sectors with the
specified pattern. In this case only the bad sectors will be filled with the
pattern, but that extremely slows the disk read process.

For example, if you set Default read attempts to 1, a bad sector will be read
2 times.

Set for all drives Click this button to reset I/O Tries for all drives to the default value.

Pattern to fill bad blocks Specifies a default pattern R-Linux will use to fill bad sectors in files to
recover, in images, or when showing data in the Text/Hexadecimal
Viewer. You may specify the pattern either in the ANSI or Hex data format.
Note: R-Linux will never ever try to write anything on the disk from which
data is to recover or an image is to create. 

Memory Usage

Memory Usage dialog box
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These settings control how much memory R-Linux uses for its work. They help preventing R-Linux from
locking when trying to perform very memory-consuming tasks like scanning large disks or processing file
systems with a lot of files.

Memory Usage settings

Disable memory control If this option is selected, the memory control is disabled.

Limit usage of the process
memory by

If this option is selected, R-Linux will automatically stop performing the
task when the amount of used virtual memory reaches the specified value.

Limit usage of the process
memory by

If this option is selected, R-Linux will automatically stop performing the
task when the amount of used physical memory reaches the specified value.

You may see how much memory R-Linux actually uses on the Memory Usage dialog box.
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II Data Recovery Using R-Linux

Depending on the situation, data recovery may vary:

1. Recovery of deleted files that have resided on an existing partition

This can be done using Basic File Recovery.

2. Recovery of files that have resided on a data disk with a damaged file system, or on a previously
deleted or re-formatted partition

If the file system on such partition is damaged, the operating system sees that partition as a partition
without a valid file system. Such partition should be previously scanned. Also, it should be scanned if you
want to recover data on a previously deleted or re-formatted partition.

When the partition is scanned, a number of recognized partitions will appear. R-Linux shows them in
different colors depending on which elements of the partition have been found.

An existing partition
An existing partition after disk scan
Both boot records and file entries are found for this partition
Only file entries are found for this partition
Only boot records are found for this partition
A deleted partition 
Empty space on the object
Files that have been found using scan for known file types.

Although such recognized partitions are virtual objects, files can be searched for and recovered from
recognized partitions as from real partitions using Basic File Recovery.

To successfully recover files from a recognized partition, it is necessary to find a right one which
corresponds to the real partition on which the files resided. No strict rules can be applied to that, but the
following considerations should be taken into account:

· If you are going to recover files from a disk with a damaged file system, most likely the right
recognized partition will be a green one.

· If you are going to recover files from a previously deleted or re-formatted partition, most likely the
right recognized partition will be a yellow one.

Also always check the recognized partition's file system, start point, and size. They should be the same for
the recognized partition and real partition. When in doubt, try to preview a couple of files from the
recognized partition. If the files are seen correctly, this is the right partition.

R-Studio Features
Contact Information and Technical Support
Basic File Recovery
Advanced Data Recovery
Mass File Recovery
Various Disk and Volume Managers
Text/Hexadecimal Viewer
Technical Information and Troubleshooting
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2.1 Basic File Recovery
NEVER TRY TO SAVE RECOVERED FILES/FOLDERS ON THE SAME PARTITION WHERE

THEY RESIDE!!!
Or you may obtain unpredictable results and lose all your data. 

Basic file recovery can be made for deleted files that has resided on an existing partition visible to the
operating system. In all other cases, Advanced Data Recovery is required. 

To recover deleted files from an existing or recognized partition,

1 Double-click a partition on the R-Linux's Drives panel to enumerate files on the disk

 Other ways to enumerate files

· Select the disk and click the Show Files button, 
or
· Right-click the selected disk and select Open Drive Files on the context menu, 
or
· Select Open Drive Files on the Drive menu

If you try to enumerate files on a hard drive or another object without a valid file system on it, a Double-

click a logical disk... message will appear. Select a partition on the object or scan the object.

> R-Linux will change its panel showing the disk's folders/files structure

R-Linux analyzes data on the object and displays all files for which records have been found in the
analyzed tables. If files have not been found, that means that their records have been deleted. To find such
files, Advanced Data Recovery is required.

Please note that R-Linux shows only those files/folders that match a specified file mask.



R-Linux for Linux Technical Documentation18

© 2025 R-Tools Technology Inc.

 R-Linux Main panel

Panel view options

You may set which panels and bars to enable/disable. To enable/disable

The Toolbar Select/clear Toolbar on the View menu

The Status bar Select/clear Status bar on the View menu

The Folders panel Select/clear Folders View on the View menu

The Files panel Select/clear Contents View on the View menu

The Log panel Select/clear Event Log on the View menu

The Find Results panel Select/clear Find Results on the View menu

R-Linux shows folder sizes and the number of files in it in the right pane.
Folder sizes

You may also arrange the data as required. On the View menu, select Arrange and them a required
arrangement.
You may specify which columns will be visible on the Files panel. On the View menu, select Contents

Columns, and select the columns you want to see.
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Files can be shown as a list or as icons/tiles of different sizes.
Files shown as icons/tiles

Recovery chances
R-Linux shows its estimates of chances for successful file recovery in the Recovery chances column. 

Recovery chances

Undefined

Good

Above average

Average

Below average

Bad

When R-Linux has enumerated files, those estimates may not be accurate and aren't available for most
files. You may improved them by right-clicking any folder on the Content pane and selecting Recheck

Recovery Chances on the context menu.

The best estimations are though after scanning the disk/partition.

File Information
You may view some information about a file. Right-click the file and select Get Info on the context
menu.

File Information
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More information

Click this button to pin the file information. This panel will show the
information about the "pinned" file regardless of the current selected
file.

Click this button to copy all this information

Click this button to select the file you want to go to. 

Click this button to close all the information. 

Folders panel

Deleted folder
Marked deleted folder
(all child objects in this
deleted folder are
marked)
Partially marked folder
(some child objects in
this folder are marked)
Extra Found Files folder

Log panel
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Files panel:

Deleted file:

Marked deleted file
Selected deleted file

Target of a hard link

Hard link to a file

Find Results panel

Reopen All Files

Click this button to list files
again.

Recover

Click this button to recover selected
folders/files.

Recover Marked

Click this button to recover marked
folders/files.

Find

Click this button to find a particular file/folder. 

Find Next

Click this button to find the next object specified in the Find dialog
window.

Find Previous

Click this button to find the previous object specified in the Find dialog
window.

File Mask

Click this button to specify a file mask.

The Unmask button appears when a mask is applied. 

Click this button to remove the applied mask.
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Up

Click this button to move highlighting one folder
up.

Options

Click this button to change Recovery
Options.

The Log panel will show how many files and folders are on the object, and their size. You may specify
which events will be shown in the log pane by setting a log filter.

Note: Metafiles are the file system's internal files invisible to any user, or file system data, which R-Linux
represents as files. These files do not contain user data directly. Unless you want to scrutinize a disk file
system, do not restore them.

If the Too many files... message appears, you may temporally stop file listing and browse through found
files. Then you can resume file listing. You also may skip this file topic and continue. R-Linux will keep
information about the entire file structure.

You may also copy the information about folders and files. 

For the folder (the Folders pane):

Click Copy Folder: To copy the folder's name

Click Copy Path: To copy the path to the folder

For the file (the Contents pane):

Click Copy (Column

Name):
To copy the file's Name, Size, Created, etc., depending on which column
is selected

Click Copy Path: To copy the file path.

Click Copy Selected

Text:
To copy all the columns of the selected file.

2 Select a file/folder to recover

You may select several files/folders in the same parent folder by pressing the Shift button and clicking the
objects simultaneously.

 Marking multiple files/folders from different parent folders manually:

Mark a file/folder to recover by clicking the box left to the object, or select Mark on the context menu.
You may mark several files/folders in different parent folders. You may mark all objects in the folder by
selecting Mark All on the Tools or context menu. To unmark an object, click the box left to the object
once more or select Unmark on the context menu. You may unmark all objects in the folder by selecting
Unmark All on the Tools or context menu.
The Log panel will show how many files and folders you have marked, and their total size.

R-Linux can search for a particular file. Go to the Searching for a File topic for details. If you need to
find and mark many files, go to the Find and Mark Multiple Files topic for details.

File content may be previewed before recovery. Go to the Previewing Files topic for details.

If you do not find files that you want to recover:
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Sometimes R-Linux can find the files but not the entire file paths to them. It puts such files into the Extra
Found Files folder. Try to search for the files there. If that does not help, try to find them by using file
search globally on the entire disk. Go to the Searching for a File topic for details

If you still cannot find files that you want to recover but are sure they have existed on the logical disk, you
need to use Advanced Data Recovery to find them.

3 Click the Recover or Recover Marked button

 Other ways to recover selected files

· Right-click the selected file/folder and select Recover or Recover Marked on the context menu, 
or
· Select Recover or Recover Marked on the File menu

4 Specify recover options and output folder on the Recover dialog box and click the OK button

Recover dialog box

 Recover options

Condense successful restoration events If this check box is selected, R-Linux recovers the folder
structure in which all files to recover reside starting from
the common topmost folder.

Restore folder structure If this check box is selected, R-Linux recovers the entire
path to the selected object.

Recover real folders structure Enabled when the files are sorted by their extensions or
date. See Find and Mark Multiple Files for details. If
this check box is selected, R-Studio recovers the real
folders/?files structure on the disk rather than that of sorted
files.

Restore from root If this check box is selected, R-Linux recovers the entire
path to the selected object starting from the root folder of
the disk.

Recover metafiles If this check box is selected, R-Linux recovers disk
metafiles. Metafiles are the file system's internal files
invisible to any user, or file system data, which R-Linux
represents as files. These files do not contain user data
directly. Unless you want to scrutinize a disk file system,
do not restore them.
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Open local folder (folders) when done Folder(s) where recovered files have been saved will be
opened upon finishing file recovery.

Recover alternative data streams If this check box is selected, R-Linux recovers alternative
data streams for file systems that support them

Recover security If this check box is selected, R-Linux recovers security
attributes for NTFS files. Has no effect on FAT files.

Recover extended attributes If this check box is selected, R-Linux recovers extended
(HPFS) file attributes.

Skip files with bad sectors If this check box is selected, R-Linux skips files with bad
sectors and displays their list on the Files with bad

sectors dialog box when the recovery has been
completed. You may separately decide later what to do
with those files. See Bad sectors for details. 
If this check box is cleared, R-Linux tries to read those
sectors several times (specified on the Settings/?Bad

Sectors dialog box), and, if fails, fills bad sectors in the
recovered file with the pattern specified on the same box.
Information about such files will appear in the Log.

Do not recover duplicate files from Extra
Found Files

If this check box is selected, R-Linux does not recover
files from Extra Found Files (raw files) that coincide with
files recovered from the file system.

Open local folder (folders) when done If this check box is selected, the folder with recovered
files will be opened upon recovery completion.

Advanced Specifies options for mass file recovery

If you want to recover multiple files at once, go to the Recover Multiple Files for more information
NEVER TRY TO SAVE RECOVERED FILES/FOLDERS ON THE SAME PARTITION WHERE

THEY RESIDE!!!
Or you may obtain unpredictable results and lose all your data.

If a file to be recovered appears to have an invalid name, a Broken File Name dialog box will appear. You
may correct the name and resume file recovery.

Broken File Name dialog box

 Broken File Name properties

File name Shows the current incorrect file name.

New name Field for a new file name.

Edit broken symbols only If this check box is selected, only invalid symbols may be
corrected

Change all invalid symbols to If this check box is selected, all invalid symbols will be
changed to the specified symbol
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Buttons

Rename Click to resume file recovery

Rename All Click to resume file recovery. All other files will be renamed
according to the specified rule.

Skip Click to skip this file

Skip All Click to skip all files and stop file recovery

> R-Linux will recover the selected/marked files/folders to the specified folder and show the results in

the Log pane

The Recovery progress indicator will show the log and progress of recovery process.

Recovery progress indicator

You may change some options during disk processes in real time

You may change some options during the process of file recovery

Note: R-Linux recovers files from Ext2/3/4FS partitions, but can write them to any local or network
disks.  R-Linux recovers symlinks as files containing the path to files which symlinks point to.

Opening several disk/partitions in one tab
Searching for a File
Finding Previous File Versions
Previewing Files
File Masks
Regular Expressions
Event Log

2.1.1 Opening several partitions in one tab

You may open several partitions in one tab. Then you may search for files and recover them from several
disks/partitions at once. This is especially useful if files are to be recovered from several recognized partitions
found on one real partition or a drive.

To open several partitions in one tab,

1 Open one partition in a usual way (double-click a logical disk, for example).

2 Right-click the next partition, select Show Files In Tab, and select the tab you want the partition
appear in, or

drag the disk/partition from the Device view to the required tab.
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Several partitions in one tab

> R-Studio for Linux will show files from several partitions in one tab

Several partitions in one tab

Now files may be searched for, marked for recovery, and recovered.

To remove a partition from the tab,

1 Right-click the required partition in the tab and select Close drive in the context menu.

Several partitions in one tab

2.1.2 Searching for a File

R-Linux can find a particular file, if it is difficult to find it manually on the Folders or Files panel. You can also
automatically mark all found files.
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To search for a file,

1 Click the Find button

 Other ways to search for the file

· Right-click a folder and select Find on the context menu, 
or
· Select a folder and select Find on the Tools menu

2 Specify a file to be found and its options on the Find dialog box, and click the OK button

Note that a File Mask may be applied.

Find/Mark dialog box

 Find/Mark options

You may specify how to treat specified strings. Please note that R-Linux stores previously entered
search strings.

Files and folders If this option is selected, R-Linux treats specified strings as file or folder names.
Use ? for one unspecified character  and * for an unlimited number of them to
specify file masks. 

File Extensions If this option is selected, R-Linux treats specified strings as file extensions

Regular
Expressions

If this option is selected, R-Linux treats specified strings as regular expressions

File Id Specifies File Id that R-Studio assigns to a file.

All Files If this option is selected, R-Linux applies Advanced Options to all files.

Match case If this check box is selected, R-Linux makes a case-sensitive search

Look at

Files If this check box is selected, R-Linux includes files into a search.

Folders If this check box is selected, R-Linux includes folders into a search. Disables when
the Mark/Unmark All option is selected.

Deleted files If this check box is selected, R-Linux makes a search among deleted files/?folders.

Existing files If this check box is selected, R-Linux makes a search among existing files/?folders.
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Look in Specifies where R-Linux searches for, and marks, files. It can look for them on the
Entire disk, or in/from a certain folder.
You may specify the starting folder for the search.

  identifies current opened folder.

  identifies current starting folder for the search.

 sets starting folder to the current opened folder.

 sets back current starting folder.

Advanced
options

If this check box is selected, R-Linux will use the advanced options. 

Size from/up to Specifies file size limits. See the Data Formats and Multipliers topic for more
details on data formats.

Recovery
Chances

Specifies files with certain recovery chances. 

Date Specifies file date boundaries. Dates for Modified, Created, and Last Accessed

timestamps may be set separately. 

The Set for all button sets the specified data for all fields.

Find/?Mark
options

Specify what R-Linux does with the found files. 
The Find first/previous/next/last options. R-Linux stops at the first/previous/next/last
file that matches the specified search criteria.
Find all files. R-Linux searches for all files that matches the specified search criteria..
The search results appear on the Find Results panel.
Mark/Unmark All. R-Linux marks/unmarks all files that match the search criteria.
When these options are selected, R-Linux  marks/unmarks files only, not folders,
regardless of what Look at: Folders specifies.
Please note, that when performing a new find and mark/?unmark task, R-Linux does
not takes into consideration the previous marked/?unmarked state of files. For
example, if you first mark all doc files, and then all txt files, all doc files remain
marked, too. To unmark them, you should specify doc once again and select
Unmark files.

> R-Linux will show/mark the found file(s)

If you need to find and mark many files, go to the Find and Mark Multiple Files topic for details.

To repeat the search, 

* Click the Find Next or Find Previous buttons

 Other ways to repeat the search

· Right-click a folder and select Find Next or Find Previous on the context menu
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or
· Select a folder and select Find Next or Find Previous on the Tools menu 

To find all files and show them on the Find Results panel, 

* Select Find all on the on the Find dialog box,

or

select Find all on the Tools menu

> R-Linux will show the found files on the Find Results panel

2.1.3 Finding Previous File Versions

R-Linux can find previous versions of files. It searches for them in the file's current folder and in Extra Found

Files.

File versions are searched for using file size. If the size of a files is within 10% of the original filesize, the
following conditions are checked: 

Conditions Legend

File name N

File extension E

Recognized file type T

To search for previous file versions,

1 Right-click the file and select Find Previous Versions of the File on the context menu

* R-Linux will show the files in the list:

File versions

This technique can be used to find deleted original files after attacks of file encrypting viruses.

2.1.4 Previewing Files

R-Linux has a built-in file previewer that allows you to preview both existing and deleted files. You may use
this feature to estimate recovery or a file to be recovered. 
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While previewing a file in the external viewer, you may recover it, mark the file for recovery, or perform other
operations using Previewer buttons.

Previewer buttons

Locate file, Mark for recovery, Previous file, Next file, Recover,
Zoom In. Zoom Out, Actual Size, Rotate Counterclockwise,
Rotate Clockwise, Fit in Window, Full Screen

To preview a file

1 Right-click a file to preview on the Files panel and select Preview on the context menu

 Other ways to preview the file

· Select the file on the Files panel and click the Preview button,
or
· Select the file on the Files panel and select Preview on the File menu

> R-Linux will show the content of the file

If you have several files open in the previewer, you may instantly close all of them by selecting Close All

Previews on the File menu.

File Previewer for Pictures:

Pictures can be previewed either as tiles within the main window of R-Lin`ux or in an external previewer.

Within the main window as tiles:

Tile size can be changed..

Pictures as tiles

In the external viewer:

Picture files can be zoomed in/out.
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Picture file previewer

File Previewer for Video and Audio files:

Video and audio files can be played even without their respective application installed.

Video file previewer

File Previewer for Microsoft/Open/Libre Office Documents:

Documents can be shown (including embedded pictures) even without their respective applications installed.
They can be zoomed in/out for better viewing.
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Microsoft/Open/Libre Office document previewer

File Previewer for Adobe Acrobat PDF Files:

Files can be shown even without Adobe Acrobat installed.

The previewer allows the users to jump to a required page, zoom the document, and search for a required
text.

Adobe Acrobat pdf document previewer

The files can be shown in different layouts and rotated. Click the View menu and select the required options.

Supported File Types:

Documents:

MS Office and Open/Libre Office files, even without the programs installed: 
· Word/Writer documents: docx;
· Excel/Calc spreadsheets: xlsx;
· PowerPoint presentation: pptx.

Office 97-2003, without the program installed:
· Word documents: doc;
· Excel spreadsheets xls;
· PowerPoint presentation ppt.
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Adobe Acrobat document: pdf.

Multimedia Files

Video formats: 
AIFF, ASF, AVI, BFI, CAF, FLV, GIF, GXF, HLS, QuickTime, 3GP, MP4, Matroska, Maxis XA,
MPEG-DASH, MPEG program stream, MPEG transport stream (including AVCHD), MXF, Material
eXchange Format, SMPTE, MSN Webcam stream, NUT, Ogg, OMA, RL2, TXD, WTV.

Audio formats: 
8SVX, AAC, AAC+, AC-3, ADPCM, AMR-NB, AMR-WB, Amazing Studio PAF Audio, Apple
lossless audio, QuickTime, ATRAC, CELT, DCA (DTS Coherent Acoustics), DPCM, DSD (Direct
Stream Digitial), DSP Group TrueSpeech, DST (Direct Stream Transfer), DV audio, FLAC (Free
Lossless Audio Codec), G.723.1, G.729, GSM, IAC (Indeo Audio Coder), iLBC (Internet Low
Bitrate Codec), IMC (Intel Music Coder), Interplay ACM, MACE (Macintosh Audio
Compression/Expansion), MACE (Macintosh Audio Compression/Expansion), MLP (Meridian
Lossless Packing), Monkey’s Audio, MP1 (MPEG audio layer 1), MP2 (MPEG audio layer 2), MP3
(MPEG audio layer 3), MPEG-4 Audio Lossless Coding (ALS), Musepack SV7/SV8, Nellymoser
Asao, AVC (Audio for Video Codec), PCM A-law/mu-law, QCELP / PureVoice, QDesign Music
Codec, RealAudio, Vorbis, Voxware MetaSound, WavPack, Westwood Audio, Windows Media
Audio, Xbox Media Audio

Graphic files (with file extensions)

3DS Max thumbnail (max), AAA logo (bpr), ACE texture (ace), ADEX (img, rle), AIM Grey Scale
(ima, im), AIPD image (aipd), ARF (arf), AT&T Group 4 (att), AT&T multigen (icn), AVHRR Image
(sst), AVT RAW (raw), AWD (awd), Ability Photopaint Image (apx), Access (g4, acc), Aces200
(ace), Acorn Sprite (acorn), AdTech perfectfax (adt), Adobe Illustrator (ai), Adobe
PhotoParade(images) (php), Adobe Photoshop (psd), Advanced Art Studio (ocp, art, pic), AirNav
(anv), Album bébé (frm), Alias Image File (pix, als, alias), Alpha Microsystems BMP (bmp), Amapi
(2d), Amica Paint (ami, [b]), Amiga IFF (iff, blk), Amiga icon (info), Amstrad Cpc Screen (cpc),
Analyze (avw), Analyze-7 (img), Andrew Toolkit raster object (atk), Apollo HDRU (hdru, hdr, gn),
ArcInfo Binary (hdr), Art Director (art), Artisan (art), Artist 64 (a64), Artrage (ptg), Artweaver
Document (awd), Astronomical Research Network (arn), Atari grafik (pcp), Aurora (sim), Auto F/X
(afx), AutoCAD DWG (dwg, dwt), AutoCAD DXF (dxf), Autocad CAD-Camera (img), Autodesk
Animator (fli, flc), Autodesk QuickCAD thumbnail (cad), Autodesk SKETCH thumbnail (skf),
Autodesk SketchUp component (skp, skb), Autologic (gm, gm2, gm4), Award Bios Logo (epa),
Axialis Screensaver(images) (ssp), B3D(images) (b3d), BFLI (bfl, bfli, fli, flp, afl), BIAS
FringeProcessor (msk, img, raw, flt), BLP textures (blp), BMF (bmf), BSB/KAP (kap), BYU SIR (sir),
Bert's Coloring (bmg, ibg), Bfx Bitware (bfx), Bio-Rad confocal (pic), Blazing Paddles (pi), Bob
Raytracer (bob), Brender (pix), Brooktrout 301 (brk, 301, brt), Brother Fax (uni), Buttonz & Tilez
texture (til), CALS Raster (cal, cals, gp4, mil), CDU Paint (cdu), CGM (cgm), CImage (dsi), CMU
Window Manager (cmu), CP8 256 Gray Scale (cp8), CSV (csv), Calamus (cpi, crg), Camera RAW
(raw), Canon EOS-1D Mark II RAW (cr2), Canon Navigator Fax (can), Canon PowerShot (crw),
Cartes Michelin (big), Casio QV-10/100 Camera (cam), Casio RAW (bay, raw), Chinon ES-1000
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digital camera (cmt), Cisco IP Phone (cip), Cloe Ray-Tracer (clo, cloe), ColoRIX (rix, sci, scx, sc?),
CompW (wlm), CompuServe GIF (gif, giff), Computer Eyes, Digital Vision (ce), ComputerEyes Raw
(ce1, ce2), Contax RAW (bay, raw), Core IDC (idc), Corel Draw Bitmap(preview) (cdr), Corel Draw
Pattern(preview) (pat), Corel Flow(preview) (bmf), Corel Metafile Exchange(preview) (cmx), Corel
PhotoPaint 6.0 (cpt), CoverDesigner(images) (ncd), CoverDesigner Template(images) (nct), Crayola
(art), Creative PC-CAM RAW (bay, raw), DBW Render (), DIV Game Studio Map (map), DIV
Game Studio Multi Map (fpg), DKB Ray-Tracer (dis), DNG (dng), DPX (dpx), Dali Raw (sd0, sd1,
sd2), Datacopy (img), Degas & Degas Elite (pi1, pc1, pi2, pc2, pi3, pc3, pi4, pi5, pi6), Deluxe Paint,
Electronic Arts (lbm, ilbm), Dicom (dcm, acr, dic, dicom, dc3), Digital F/X (tdim), Digital
Research(GEM Paint) (img, gem), Direct Draw Surface (dds), Discorp CMP Image (cmp), DjVu (djvu,
djv, iw4), DolphinEd (dol), Doodle Atari (doo), Doodle C64 (dd), Doodle C64(Compressed) (jj), Dr
Halo (cut), Draz Paint (drz), EA Sports FSH (fsh), EPS Interchange Format (epi, ept), ERI-chan(Entis
Rasterized Image) (eri), ESM Software Pix (pix), Ecchi (ecc), Eclipse (tile), Edmics (c4), Egg Paint
(trp), Electric Image (ei, eidi), Embroidery (bmc), Encapsulated Postscript (ps, eps), Encapsulated
Postscript (Preview) (eps), Enhance Simplex (esm), Enhanced Compressed Wavelet (ecw), Epson
RAW (erf), Eroiica (eif), Everex Everfax (efx, ef3), Explore(TDI) & Maya (iff, tdi), FIF(Iterated
System) (fif), FIT (fit), Face Painter (fpt), Fast Piecewise-constant (pwc), Fax Group 3 (g3, fax), Fax
man (fmf), Faxable PCX (fcx), Faxable TIFF (ftf), Fenix Map (map), Fenix Multi Map (fpg), FileMagic
(mag), Flash Image (fi), FlashCam Frame (ncy), FlashPix Format (fpx), Flexible Image Transport
System (fts, fits, fit), Foculus RAW (bay, raw), Fontasy Grafik (bsg), Fremont Fax96 (f96), Fugawi
Map (fx3), Fuji S2 RAW (raf), Fun Painter II (fp2, fun), Fun Photor (fpr), Fuzzy bitmap (fbm, cbm),
GRS16 (g16), Gamma Fax (gmf), GeoPaint (geo), Gfa Raytrace (sul), GigaPaint Hi-res (gih), GigaPaint
Multi (gig), Gimp Bitmap (xcf), Gimp Brush (gbr), Gimp Icon (ico), Gimp Pattern (pat), GoDot (4bt,
4bit, clp), GunPaint (gun, ifl), HD Photo (wdp, hdp), HDRI (hdr, hdri), HF (hf), HP-48/49 GROB (gro,
grb), HP-49 OpenFire (gro2, gro4), HPGL-2 (hp, hpg, hgl, plt, hpgl, hpgl2, gl2, prn, prt, spl), HRU
(hru), HSI Raw (raw), Half-Life Model (mdl), Hasselblad RAW (3fr), Hayes JTFax (jtf), Hemera
Photo Image (hpi), Hemera Thumbs (hta), Heretic II MipMap (m8), Hi-Eddi (hed), Hires C64 (hir,
hbm), Homeworld Texture (lif), IBM Kips (kps), IBM Printer Page Segment (pse), IM5(Visilog) (im5),
IMNET Image (imt), IOCA (ica, ioca, mod), IPLab (ipl), IPod thumb (ithmb), ISS (iss), IcoFX (ifx),
Icon Library (icl), Imacon/Hasselblad RAW (fff), Image Capture Board (icb), Image Magick file (mif,
miff), Image Speeder (ish), Image System(Hires) (ish), Image System(Multicolor) (ism), Image Systems
RLC2 Graphic (rlc), ImageLab (b&w, b_w), ImagePro Sequence (seq), Imaging Fax (g3n), Imaging
Technology (img), Img Software Set (img), Inshape (iim), InterPaint(Hires) (iph), InterPaint(Multicolor)
(ipt), Intergraph Format (itg, cit, rle), Interleaf (iimg), Iris CT (ct), Iris Graphics (iris), J Wavelet Image
Codec (wic), JBIG (jbg, bie, jbig), JBIG-2 (jb2), JFIF based file (jb2), JPEG / JFIF (jpg, jpeg, jif, jfif,
J, jpe), JPEG 8BIM header(Mac) (jpg, jpeg, jif, jfif, J, jpe), JPEG XR (jxr), JPEG-2000 Code Stream
(jpc), JPEG-2000 JP2 File Format (jp2, j2k, jpx, jpf), JPEG-LS (jls), Jeff's Image Format (jif), Jigsaw
(jig), Jovian VI (vi), Jpeg Network Graphics (jng), JustButtons animated bitmap (btn), KONTRON
(img), Khoros Visualization Image file (vif, viff, xv), KinuPix Skin (thb), Kiss Cel (cel), Koala Paint
(koa, kla), Koala Paint(Compressed) (gg), Kodak Cineon (cin), Kodak DC120 Digital Camera (kdc),
Kodak DC25 Camera (k25), Kodak Photo CD (pcd), Kodak Pro Digital RAW (dcr), Kofax Group 4
(kfx), Kolor Raw Format (kro), Konica Camera File (kqp), LSS16 (lss, 16), LView Pro (lvp),
LaserData (lda), Leaf RAW (mos), Leica RAW (bay, raw), Light Work Image (lwi), LucasFilm Format
(lff), Lumena CEL (cel), LuraDocument Format (ldf), LuraDocument.jpm Format (jpm), LuraWave
Format (lwf), LuraWave JPEG-2000 Code Stream (jpc), LuraWave JPEG-2000 Format (jp2, j2k,
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jpx, jpf), MAKIchan Graphics (mag), MGI Photosuite Project(images) (pzp), MGR bitmap (mgr),
MRC(Medical Research Council) (mrc), MTV Ray-Tracer (mtv), Mac Paint (mac, mpnt, macp, pntg,
pnt, paint), Mac icon (icns), Macintosh Quickdraw/Pict (pic, pict, pict2, pct), Mac OSX Resource (rsc,
rsrc), Maggi Hairstyles & Cosmetics (fff), Male MRI (pd, t1, t2), Male Normal CT (fre), Mamiya
RAW (mef), Marks Russel File (mrf), Mavica (411), Maw-Ware Textures (mtx), Mayura Draw (pdx),
MegaPaint (bld), Megalux Frame (frm), Micro Dynamics MARS (pbt), Micro Illustrator Uncompressed
(mil), Micrografx Picture Publisher 4.0 (pp4), Micrografx Picture Publisher 5.0 (pp5), Micron RAW
(bay, raw), Microsoft Image Composer (mic), Microsoft Paint (msp), Microtek Eyestar (img),
Mindjongg Format (ipg), Minolta DiMAGE RAW (mrw), Mobile FAX (rfa), MonkeyCard (pdb),
MonkeyLogo (pdb), MonkeyPhoto (mph), MrSid (sid), Msx 2 Screen (sc2), Multiple Network
Graphics (mng), NCR Image (ncr), NIST ihdr (pct), National Imagery Transmission F. (ntf, nitf),
NeoBook Cartoon (car), Neochrome(ST & TT) (neo), Neopaint Mask (npm), Neopaint Stamp (stw),
NewsRoom (nsr, ph, bn), Nifti (img), Nikon RAW (nef), Nokia Group Graphics (ngg), Nokia Logo
File (nlm), Nokia OTA bitmap (otb), Nokia Operator Logo (nol), OAZ Fax (oaz, xfx), OS/2 Bitmap
(bmp, bga), Olicom Fax (ofx), Olympus RAW (orf), Open Image Library Format (oil), OpenEXR
(exr), Optigraphics (ctf), Optigraphics Tiled (ttf), Optocat (abs), Oric Hires (hir), Oric TAP (tap), Os/2
Warp (bga), PABX background (pix), PAX (pax), PC Paint / Pictor Page (pic, clp), PCO (b16), PM
(pm), Page Control Language (pcl), Paint Magic (pmg), PaintShopPro Browser Cache File (jbf),
PaintShopPro Brush (pspbrush), PaintShopPro Brush (jbr), PaintShopPro Frame (pfr, pspframe),
PaintShopPro Image (psp, pspimage), PaintShopPro Mask (pspmask), PaintShopPro Mask (msk),
PaintShopPro Pattern (pat), PaintShopPro Picture Tube (tub, psptube), PaintShopPro Texture (tex),
Palm Pilot (pdb), Panasonic DMC-LC1 RAW (srf), Panasonic LX3 RAW (rw2), Panasonic RAW
(bay, raw), Pegs (pxs, pxa), Pentax *ist D (pef), Pfs Art Publisher (art), Photo Deluxe (pdd, pdb),
Photo Filtre Studio (pfi), PhotoFantasy Image (fsy), PhotoFrame (frm), PhotoStudio File (psf),
PhotoStudio Stamp (stm), Photomatrix (cat), Pic2 (p2), Picasso 64 (p64), Picture Gear Pocket (prc),
Picture It! (mix), Pixar picture file (pic, pxr, picio, pixar), Pixel Power Collage (ib7, i17, i18, if9), Pixia
(pxa), Pixibox (pxb), Planetary Data System (pds, img), Playback Bitmap Sequence (bms), Pocket PC
Bitmap (2bp), Pocket PC Themes(images) (tsk), Polychrome Recursive Format (prf), Portable Bitmap
(pbm, rpbm, ppma), Portable Document Format (pdf), Portable Greyscale (pgm, rpgm), Portable
Image (pnm, rpnm, pbm, rpbm, pgm, rpgm, ppm, rppm), Portable Network Graphics (png, apng),
Portable Pixmap (ppm, rppm), Portfolio Graphics (pgf), Portfolio Graphics Compressed (pgc), Portrait
(cvp), Poser Bump (bum), Postscript (ps, ps1, ps2, ps3, eps, prn), PowerCard maker (crd),
PowerPoint(images) (pps), PowerPoint Presentation(images) (ppt), Print Master (pm), Print Shop (psa,
psb), Printfox/Pagefox (bs, pg, gb), Prism (cpa), Prisms (pri), Psion Series 3 Bitmap (pic), Psion Series
5 Bitmap (mbm), Punk Productions Picture (ppp), Puzzle (pzl), Q0 (q0, rgb), Qdv(Random Dot
Software) (qdv), Qrt Ray-Tracer (qrt), Quake Texture (wal), Quantel VPB (vpb), QuickTime Image
Format (qtif, qti), RAW DVR (raw), RIPTerm Image (icn), Radiance (rad, img, pic), Rainbow Painter
(rp), Raw (raw, gry, grey), Rawzor (rwz), Rayshade (pic), Red Storm File Format (rsb), Ricoh Digital
Camera (j6i), Ricoh Fax (001, ric), Ricoh IS30 (pig), Rm2K XYZ (xyz), Rollei RAW (rdc, ia),
RoverShot RAW (bay, raw), RunPaint(Multicolor) (rpm), Saracen Paint (sar), SBIG CCD camera ST-
4 (st4), SBIG CCD camera ST-X (stx, st4, st5, st6, st7, st8), SciFax (sci), SciTex Continuous Tone
(sct, ct, ch), Seattle Film Works (sfw), Seattle Film Works multi-image (pwp, sfw), SecretPhotos puzzle
(xp0), Sega SJ-1 DIGIO (sj1), Sharp GPB (img), Siemens Mobile (bmx), SIF MICHEL-Soft (sif),
Sigma RAW (x3f), Silicon Graphics RGB (rgb, rgba, bw, iris, sgi, int, inta), Sinar RAW (cs1, sti),
Skantek (skn), Slow Scan Television (hrz), SmartDraw 6 template (sdt), SmartFax (1), SmoothMove
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Pan Viewer (pan), Softimage (pic, si), Solitaire Image Recorder (sir), Sony DSC-F1 Cyber-shot (pmp),
Sony DSC-F828 RAW (srf), Sony PS2 TIM (tm2), Sony Playstation TIM (tim), Sony RAW (sr2,
arw), Spectrum 512 (spu), Spectrum 512(Compressed) (spc), Spectrum 512(Smooshed) (sps), SPOT
(dat), SriSun (ssi), Stad (pic, pac, seq), Star Office Gallery (sdg), Starbase (img), Stardent AVS X (x,
avs, mbfs, mbfavs), Starlight Xpress SX (RAW), Stereo Image (jps), ST Micro RAW (bay, raw),
Structured Fax Format (sff), Sun Icon/Cursor (icon, cursor, ico, pr), Sun Rasterfile (ras, rast, sun, sr,
scr, rs), Sun TAAC file (iff, vff, suniff, taac), Syberia texture (syj), Synthetic Universe (syn, synu), SVG
(svg), TG4 (tg4), TI Bitmap (92i, 73i, 82i, 83i, 85i, 86i, 89i), TIFF Revision 6 (tif, tim, tiff), TMSat
image (imi), TRS 80 (hr), TealPaint (pdb), Teli Fax (mh), Thumbnail (tnl), TilePic (tjp), Tiny (tny, tn1,
tn2, tn3), TopDesign Thumbnail (b3d, b2d), Total Annihilation (gaf), Truevision Targa (tga, targa, pix,
bpx, ivb), Ulead Pattern (pst), Ulead PhotoImpact (upi), Ulead Texture(images) (pe4), Usenix
FaceServer (fac, face), Utah raster image (rle, urt), VIPS Image (v), VITec (vit), VRML2 (wrl), Venta
Fax (vfx), Verity (vif), Vicar (vic, vicar, img), Vidcom 64 (vid), Video Display Adapter (vda), Vista
(vst), Vivid Ray-Tracer (img), Vort (pix), Vue d'esprit (vob), WAD(Half life) (wad), WSQ (wsq),
WaveL (iwc), Wavefront Raster file (rla, rlb, rpf), WebShots(images) (wb1, wbc, wbp, wbz), Weekly
Puzzle (jig), WebP (webp, wep), Whypic (ypc), WinFAX (fxs, fxo, wfx, fxr, fxd, fxm), WinMIPS (pic),
Windows & Aldus Metafile (wmf), Windows Animated Cursor (ani), Windows Bitmap (bmp, rle, vga,
rl4, rl8, sys), Windows Clipboard (clp), Windows Comp. Enhanced Metafile (emz), Windows
Compressed Metafile (wmz), Windows Cursor (cur), Windows DIB (dib), Windows Enhanced
Metafile (emf), Windows Icon (ico), Winzle Puzzle (wzl), Wireless Bitmap(level 0) (wbmp, wbm, wap),
Word Perfect Graphics(images) (wpg), Worldport Fax (wfx), X Windows System dump (xwd, x11),
X11 Bitmap (xbm, bm), X11 Pixmap (xpm, pm), XV Visual Schnauzer (p7), Xara(images) (xar),
Xerox DIFF (xif), Ximage (xim), Xionics SMP (smp), YUV 16Bits (yuv, qtl, uyvy), YUV 16Bits
Interleaved (yuv, qtl, uyvy), YUV 4:1:1 (yuv, qtl), YUV 4:2:2 (yuv, qtl), YUV 4:4:4 (yuv, qtl), ZX
Spectrum Hobetta ($s, $c, !s), ZX Spectrum Snapshot(sna), ZX Spectrum standard (screen scr), ZZ
Rough (rgh), Zeiss BIVAS (dta), Zeiss LSM (lsm), Zoner Callisto Metafile(zmf), Zoner Zebra Metafile
(zbr), Zsoft Multi-page Paintbrush (dcx), Zsoft Publisher's Paintbrush (pcx, pcc, dcx), byLight (bif)

2.1.5 File Masks

R-Linux shows only those files/folders that match the specified file mask. File mask affects files/folders that
are processed by the Recover and Find commands. 

To specify a file mask,

1 Click the File Mask button

 Other ways to specify the file mask

· Right-click a folder and select File Mask on the context menu
or
· Select the folder and select File Mask on the Tools menu
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2 Specify the file mask on the File mask dialog box and click the OK button

Mask dialog box

 File mask options

You may specify options for All Files, File Extensions, File Masks, and Regular Expressions

Match case If this check box is selected, R-Linux makes a case-sensitive search.

Show empty folders If this check box is selected, R-Linux will show folders with no files matching the
mask.

Deleted files If this check box is selected, R-Linux makes a search among deleted
files/folders.

Existing files If this check box is selected, R-Linux makes a search among existing
files/folders.

Use advanced
options

If this check box is selected, R-Linux will use the advanced options, even when
they are hidden. 

Advanced Options

Size from/up to Specifies file size limits. See the Data Formats and Multipliers topic for more
details on data formats.

Date Specifies file date boundaries. Dates for Modified, Created, and Last Accessed

timestamps may be set separately. The Set for all button sets the specified data
for all fields.

The Set for all button sets the specified data for all fields.

> R-Linux will show only those files that match the specified file masks

Mask presets

You may set various presets with different file masks. Just click on the Plus button to add the data from the
dialog box to the presets. You may also give presets names, delete them, and store them permanently.

2.1.6 Regular Expressions

Regular expression is a notation for patterns of text, as opposed to exact strings of characters. The notation
uses literal characters and metacharacters. Every character which does not have special meaning in the
regular-expression syntax is a literal character and matches an occurrence of that character. For example,
letters and numbers are literal characters. A metacharacter is a symbol with special meaning (an operator or
delimiter) in the regular-expression syntax.
.  Wildcard: any character
* Repeat: zero or more occurrences of previous character or class
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^ Line position: beginning of line
$ Line position: end of line
[class] Character class: any character in the set
[^class] Inverse class: any character not in the set
[x-y] Range: any characters within the specified range
\x Escape: literal use of metacharacter x
\<xyz Word position: beginning of the word
xyz\> Word position: end of the word

For example, the following regular expression .* matches any string of characters, ^a matches any string
beginning with character a.

2.1.7 Event Log

R-Linux logs and displays events in the Log panel. You may set a Log filter to display only needed
information and to write it to a log file. You may specify the log settings on the Settings dialog box.

You may clear or save the log 

To clear the log,

* Right-click the Log panel and select Clear Log on the context menu.

To save the log to a file,

* Right-click the Log panel and select Save Log to File on the context menu.

2.2 Advanced Data Recovery
This chapter explains how to perform advanced data recovery operations.

· Disk Scan
· Regions
· Exclusive Regions

· Images

2.2.1 Disk Scan

In order to completely analyze data structure on an object, it must be scanned. Any object on the Drives

panel can be scanned. In addition, you may create a region to scan only a part of an object. The Regions
topic explains how to create and work with regions. Scan is also greatly improves estimations for chances of
successful file recovery.

You may select scan area and some other scan parameters. Scan information may be saved to a file and later
this file may be opened.
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Attention: Scanning large areas may be a very lengthy process!

NEVER TRY TO SAVE SCAN INFORMATION ON THE OBJECT BEING SCANNED!!!
Or you may obtain unpredictable results and lose all your data. 

To scan an object

1 Select an object on the R-Linux's Drives panel

2 Click the Scan button

 Other ways to start scan

· Right-click the selected disk and select Scan on the context menu, 
or
· Select Scan on the Drive menu

3 Specify the required parameters on the Scan dialog box and click the Scan button

Scan dialog box

 Scan options

Disk Size: Shows the size of the object to be scanned
Start: Sets the start point of the area to be scanned.
Size: Sets the size of the area to be scanned. 
Numbers in these fields can be in bytes or sectors. See the Data Formats and Multipliers topic for
more details on data formats.
File Systems: Specifies the file systems which objects are to be searched for.

Current version supports: Ext2/3/4FS.
Extra search for
Known File Types

Enables search for Known File Types.

Save scan Info to
File:

If this checkbox is selected, R-Linux will save scan information to a specified file.
Later this file may be opened. Please note, that this option does not save actual disk
data, only information on disk data structure gathered during disk scan.

Buttons
Scan Starts scanning
Advanced Activates advanced scan options
Known File
Types...

Selects file types that R-Linux will recognize during the disk scan.

Cancel Closes the dialog box
NEVER TRY TO SAVE SCAN INFORMATION ON THE OBJECT BEING SCANNED!!!

Or you may obtain unpredictable results and lose all your data. 

Known File Types: While scanning, R-Linux can recognize to which particular file type the data belong.
Using such information, R-Linux can obtain more information about data/file structure on the object being



R-Linux for Linux Technical Documentation40

© 2025 R-Tools Technology Inc.

scanned. By default, R-Linux tries to recognize all supported file types, greatly increasing time required
for the scan. You may reduce it by selecting only those file types that you need. Click the Known File

Types... button and select the required file types on the File Types dialog box.

File Types dialog box

Known File Types

Set as Default Click this button to set the current list of selected file types as default values.

Revert to Default Click this button to revert the default settings specified on the Known File Types

tab of the Settings panel.

Reset to
Recommended

Click this button to revert to factory-preset default settings.

Select All Click this button to select all file types in the list.

Clear All Click this button to clear all file types in the list except some predefined ones.

 List of known file types

* By default, files of this type are not selected. If necessary, select them manually

Document

Adobe PDF document Microsoft Word2
document

Microsoft WordPad
document

OLE Storage

PostScript document Rich Text document TEX document Word for Macintosh
document

WordPerfect document

Document: Spreadsheet

Lotus worksheet Lotus3 worksheet * Microsoft Excel2
worksheet

Microsoft Excel3/4
worksheet

Quattro Pro worksheet

Document: Database

Data Interchange
Format file

Microsoft Access
database

dBase III database Microsoft SQL
database

Microsoft SQL Log

Document: MS Office (OLE MS) (Word/Excel/PowerPoint)

Microsoft Word
document

Microsoft Excel
document

Microsoft PowerPoint document

Internet-related files
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Compiled HTML file HTML document Internet shortcut Outlook Express
Messages

Windows Address
Book

XML document XML document
(Unicode)

The Bat! Address book

The Bat! Message
Base

The Bat! Message
Index

Font

Adobe PostScript Font Adobe Printer Font BDF Unix font BGI font

CPI DOS font TrueType font

Graphics/Picture

AVHRR Satellite image Adobe Photoshop
image

Agfa/Matrix Scodl
image

Alias Wavefront Raster
image

AutoCAD Binary
image

AutoCAD image Autodesc Animator Pro
color map

Autodesc Animator Pro
image

Autodesc Animator
image

Autologic image BMF image ColoRIX image

CompuServe GIF
image

ComputerEyes Raw
image

Continuous Edge
Graphic image

Corel Texture image

CorelDraw CMX
image

CorelDraw image Cubicomp Picture
Maker image

Dr. Halo palette

Enhanced MetaFile
image

Epson Stylus image Erdas LAN/GIS image Fractal Image Format

GEM Raster image * GEM VDI image GOES Satellite image Gridded Binary image

HP Command
Language image

HP Raster image Hitachi Raster image IBM Picture Maker
image

JPEG image JPEG-LS image HSI JPEG image Jovian Logic image

LBM/IFF image Lotus PIC image Macintosh PICT image Macintosh PICT image

Macintosh Paint image Macintosh Paint image Microsoft Paint image PBM image

PGM image PIX image PM image PNG image

PPM image Pictor PC Paint image Quick Link II fax image RenderMan image

SGI image STAD image Sketch image Sun Raster image

Tagged Image Format
File

TrueVision image Utah Raster Toolkit
image

VITec image

Windows Animated
cursor

Windows Bitmap image Windows Fax Cover
image

Windows MetaFile
image

Windows cursor Windows icon WordPerfect Graphics
image

X PixMap image
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X Window Dump
image

ZSoft PCX image

Multimedia: Audio Files

AIFF sound AVR sound Advanced Streaming
Format file

AudioCD file

CMF music Creative Voice file DiamondWare sound EA ASF/MUS audio
file

Extended M3U playlist MIDI Instrument
definition

MIDI music MIDI stream

MPEG Layer I audio
file *

MPEG Layer II audio
file *

MPEG Layer III audio
file

MUS music

Next/Sun sound Ogg Vorbis audio file RIFF MIDI music RK Audio sound

Sierra AUD sound VQF sound Westwood AUD sound Windows Media Audio
File

Windows WAVE
sound

X-MIDI music ZyXEL sound

Multimedia: Video Files

ANIM animation Adobe Filmstrip
animation

BINK video DVM video

DeluxePaint animation Director video Intel DVI video Interplay MVE video

LZA animation MPEG video NEOchrome animation Nullsoft Video

QV-10 video QuickTime video RPL video Shockwave video

Smacker video VideoCD video Windows AVI video

Multimedia Files

RIFF Multimedia File Real Networks
audio/video

Archive Files

7-Zip archive ACE archive AIN archive ARJ archive

ARX archive Aladdin Systems StuffIt
archive

BAG archive BIX archive

BOA archive BZip2 archive BlackHole archive Blink archive

CPIO archive CRUSH archive ChArc archive Compress archive

FOXSQZ archive GZip archive HA archive * HAP archive

HPACK archive Hyper archive InstallShield Cabinet
archive

InstallShield Data
archive

InstallShield archive JAM archive JAR archive JRC archive

LHA/LZARK archive LIMIT archive LZA archive LZOParchive
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LZSH archive LZX archive Microsoft Cabinet
archive

Microsoft Compress 5
archive

Microsoft Compress 6
archive

PAKLEO archive Pack archive * QFC archive

Quantum archive * Quark archive RAR archive RPM archive

ReSOF archive SAR archive SBC archive SCO archive *

SQZ archive SZip archive StuffIt archive TAR archive

UFA archive UHArc archive UltraCompressor 2
archive

UltraCrypt 2 archive

WIN-Freeze archive * WRAptor archive WinImp archive YAC archive

YBS archive ZIP archive ZOO archive ZZip archive

Executable/Library/DLL

DOS Style Executable ELF Executable
(UNIX)

ELF Library (UNIX) ELF Module (UNIX)

Java Bytecode Novell NetWare
executable

RDOFF executable

Development files

COM Type library
Library

Microsoft ClassWizard
file

Microsoft Linker
database

Microsoft Precompiled
header

Microsoft Program
database

Microsoft Visual C++
project

Microsoft Visual Studio
project

Microsoft Visual Studio
workspace

OMF Object library Windows Compiled
resource (16bit) *

Windows Compiled
resource (32bit)

Other file types

RegEdit file RegEdit file
(UNICODE)

WinHelp WinHelp Contents

Windows Clipboard
file *

Windows Color Profile Windows National
locale

Windows Password file

Windows Policy file Windows Registry file Windows Registry hive Windows shortcut

> R-Linux starts scanning the object, and its panel will show information about new found objects: 
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The Log pane will show scan progress. Scan may be stopped by clicking the Stop button on the tab.
Later the scan process may be resumed with different scan parameters. Some scan parameters may also
be changed during the scan process. Click the Options button and change them on the Scanning dialog
box.

 R-Linux Main panel

Drives panel after scanning:

You can select an object by clicking on it
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You may see which file object(s) is/are on a particular disk part. Click the corresponding rectangle on the
Scan Information pane and view the information on the Scan Information dialog box.

Scan Information dialog box

Select the file object and click Open in Hex Viewer to view the file object in the Text/Hexadecimal
Viewer.

When an object is scanned, a number of Recognized partitions will appear. R-Linux shows them in
different colors depending on which elements of the partition have been found.

An existing partition
An existing partition after disk scan
Both boot records and file entries are found for this partition
Only file entries are found for this partition
Only boot records are found for this partition
A deleted partition 
Empty space on the object
Files that have been found using scan for known file types.

Although such recognized partitions are virtual objects, files can be searched for and recovered from
recognized partitions as from real partitions using Basic File Recovery.

To see the information about a newly found object, simply click it on the Drives panel. Click this link to
see the information about the object Recognized5 on the partition:.
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When an object in a scanned drive is selected, R-Linux shows the scanned area of the object.

Object's scanned area

All scanned information may be deleted on the context menu for a scanned object. 

Scan information may be saved in a file. Previously saved scan information may be loaded. This can be done
on the Drive or context menu for a selected object.

Resuming incomplete scans or scanning the object with different parameters

You may resume the scan of an incompletely scanned object or rescan the already scanned object with
different parameters. The  Scan dialog will be a little bit different in this case.

Scan dialog box for incomplete scans

You may rescan the entire disk, scan unscanned areas, or scan an explicitly  specified area. 

Scan of multiple areas

You may simultaneously scan several  successive or overlapping areas. Click the Advanced button, specify an
offset and size for a new area to scan on the Advanced Scan dialog box and click the Add button. You may
specify and add several scan areas. You may select which areas should be scanned. Selected scan areas can
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be merged. Right-click a necessary area and select either Merge Down, Merge Down All, and Merge

Selected. You may also select/unselect unscanned areas.

Advanced Scan dialog box

R-Linux accumulates the information from successive scans and keeps track of changes in this information
obtained from different scans.

Managing scan information

Scan information may be saved to a file. Previously saved scan information may be loaded. 

To save scan information

1 Select an object on the R-Linux Drives panel

2 Select Save Scan Information on the Drive or context menu and save the scan information in a file

The default file extension is *.scn.

To load scan information

1 Select an object on the R-Linux Drives panel

2 Select Open Scan Information on the Drive or context menu and select the required file with the
scan information

The default file extension is *.scn.

> The scan information will appear in the Drives panel

To remove scan information

1 Select an object on the R-Linux Drives panel

2 Select Delete Scan Information on the Drive or context menu

> The scan information will disappear from the Drives panel

NEVER TRY TO SAVE SCAN INFORMATION ON THE OBJECT BEING SCANNED!!!
Or you may obtain unpredictable results and lose all your data. 

2.2.2 Regions

Scanning large objects may take a long time. Sometimes, only a smaller area of a disk needs to be scanned or
searched for files. Such area is called a region. A region can be created on any object in the R-Linux's
Drives panel. 

Created regions can be scanned, and files on them can be recovered in the same way as from hard drives or
partitions.
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Created regions can be deleted.

Note: R-Linux does not create anything real on the disk. Regions are virtual objects that do not affect actual
data on the disk.

To create a region

1 Select an object on the R-Linux's Drives panel and click the Create Region button

 Other ways to create the region

· Right-click the selected object and select Create Region on the context menu
or
· Select the object and select Create Region on the Create menu

2 Specify required parameters on the Create region dialog box and click the Create button

Create region dialog box

 Region options

Disk size: Shows size of the object where the region is to be created. The region cannot be larger
than this size.

Start: Start point of the region

Size: Size of the region. Cannot be larger than Disk size.

Numbers in these fields can be in bytes or sectors. See the Data Formats and Multipliers topic for
more details on data formats.

> A Region object will appear on the Drives panel. 

To change the size of a region

* Right-click the Region on the R-Studio Drives panel, select Edit on the shortcut menu, and enter a
new size on the Edit Region dialog box.

To convert a region into an exclusive one

* Right-click the Region on the R-Studio Drives panel and select Exclude area on the shortcut menu

To delete a region

* Select a Region on the R-Linux Drives panel and click the Delete button, or

Right-click the selected region and select Delete Region on the context menu.

2.2.3 Exclusive Regions

Exclusive regions are areas on any object visible on the the R-Linux's Drives panel that are excluded from
disk operations. R-Linux never tries to read/write data from/to such area. Exclusive regions are necessary
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when, for example, there are areas with bad sectors on a hard drive, and it is necessary to avoid any disk
operations with such areas to not inflict further damage to such drive and to speed work with it. 

Note: R-Linux does not create anything real on the disk. Exclusive regions are virtual objects that do not
affect actual data on the disk.

To create an exclusive region

1 Right-click  an object on the R-Linux's Drives panel and select Create Exclusive Region on the

shortcut menu, or

Select the object and select Create Exclusive Region on the Create menu

2 Specify required parameters on the Create Exclusive Region dialog box and click the Add  button

Create exclusive region dialog box

 Exclusive Region options

Offset: Start point of the exclusive region

Size: Size of the exclusive region. Cannot be larger than Disk size.

Numbers in these fields can be in bytes or sectors. See Data Formats and Multipliers for more
details.

> An Exclusive Region object will appear on the Drives panel. 

Its properties can be seen on the Excluded Areas tab.

To delete an exclusive region

* Select an Exclusive Region on the R-Linux Drives panel and click the Delete button, or

Right-click the selected region and select Remove Region on the context menu.
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To change the size of an exclusive region

* Right-click an Exclusive Region on the R-Linux Drives panel, select Edit on the context menu, and
add/delete excluded areas on the Edite Exclusive Region tab.

You may delete an excluded area by right-clicking it and selecting Remove on the context menu.

2.2.4 Images

An image is an exact, byte by byte, copy of any object on the Drives panel. When created, images can be
processed like their original objects. 

Images are very useful if there is a risk of total data loss due to hardware malfunction. If bad blocks are
constantly appearing on a hard drive, you must immediately create an image of this drive.

While creating images, R-Linux can simultaneously perform disk scan and save scan information to lessen
time necessary to process the disk. 

All data search, scan and restoring can be done from this image.

To create an image,

1 Select an object on the R-Linux's Drives panel and click the Create Image button

 Other ways to create the image

· Select the object and select Create Image on the Drive menu
or
· Right-click the selected object and select Create Image File on the context menu

2 Specify image options, a file name, and destination for the image on the Create Image dialog box

Note: To store an image file, you need a free space equal to at least the object size.

Create Image dialog box

Create Image (Scan Information) dialog box
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Create Image dialog box

 Image Options

Image name Specifies the name and path for the image file

Plain image If this option is selected, R-Linux will create a simple exact copy of the
object. This image format is compatible with the previous versions of
R-Linux.

Compressed image (R-Drive
Image compatible)

If this option is selected, R-Linux will create an image file which can be
compressed, split into several parts, and password-protected. This
image file is fully compatible with the images created by R-Drive
Image, but incompatible with the previous versions of R-Linux.

Image compression ratio You may compress the data in the image to save space. Active only if
the Compressed image (R-Drive Image compatible) is selected.

Estimated size Shows the estimated size of the image file. An actual image size
depends on how much empty space is on the selected partition and
what file types are there. Active only if the Compressed image (R-Drive

Image compatible) is selected.

Image split size You may set this option to Automatic and let the system decide how to
split the image file. This mostly depends on the file system on the
destination disk. You may also either explicitly specify the split size, or
choose a preset for various devices with removable storage. Select
Fixed size for that. Active only if the Compressed image (R-Drive Image

compatible) is selected.

Password
Encrypt image

You may protect your image file with a password. Note: If you leave
the Encrypt image option clear this feature will provide a relatively
moderate protection against conventional unauthorized access. If this
option is selected, R-Linux will encrypt the image using the AES-XTS
algorithm.
Note: Only files in the RDR format can be password protected and
encrypted.

Create scan information file If this option is selected, R-Linux will perform disk scan simultaneously
with image creation. See the Disk Scan help page to learn scan options

Read retires Specifies a value for I/O Tries, or how many times R-Linux will try to
read a bad sector. 

https://www.R-Studio.com/What-is-AES-XTS-encryption.html
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R-Linux treats bad sectors in the following way:
It reads a certain part of disk (predefined by Windows) and
· If Default read attempts is set to 0, the entire part with bad sectors will

be filled with the specified pattern. 
· If Default read attempts is set to a non-zero value, R-Linux reads

again that part sector by sector, repeating the attempts the specified
number of times. If R-Linux still cannot read a bad sector, it fills the
sectors with the specified pattern. In this case only the bad sectors
will be filled with the pattern, but that extremely slows the disk read
process.

For example, if you set Default read attempts to 1, a bad sector will be
read 2 times.

Pattern to fill bad blocks Specifies a pattern R-Linux will use to fill bad sectors in this image.
You may specify the pattern either in the ANSI or Hex data format.
Note: R-Linux will never ever try to write anything on the disk from
which data is to recover or an image is to create. This pattern fills bad
sectors only in the image.

> R-Linux will start creating the image, the Progress message showing the progress.

You may change some options during the imaging process. Click the Options button and change them as
necessary.

You may stop the imaging process and then resume it later on. Click the Stop button and the Cancel

drive operation dialog box will appear. Select Stop if yo want to keep the partially created image or
Discard if you don't need this image file.

To resume the creation of the image for the same object, select the same file name for the image. You'll be
able to create a new image file or continue to create the image for the object.

R-Linux will create a new file for every new start of imaging for the .rdi file type.

To process an already created Image, the image file should be opened.

To open an image

1 Click the Open Image button, or

Select Open Image File on the Drive menu
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2 Select the required image file 

> An Image object will appear on the Drives panel

Depending whether this is a byte-by-byte, compressed (R-Drive Image compatible), or multi-volume,
image, its appearance in the Drives panels is different.

You may perform all data search, scan, and recovery from this image as it were a regular drive/?disk
object.

A compressed (R-Drive Image compatible) image

A byte by byte  image

A multi-volume image

To close an image

* Select the image and click the Close Image button,

· or right-click the image and select Close Image on the shortcut menu

· or select the image and press the F8 key.
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To close all image

* Select Close All Images on the Tools menu

A logical disk (or disks) containing in an image can be mounted in the operating system as a device which
makes its content accessible to any program including any other data recovery software.

2.3 Mass File Recovery

Recovery of multiple files

If you need to recover multiple files you may do it through the following steps:

1 Find and mark all the necessary files

Go to the Find and Mark Multiple Files topic for more information

2 Recover all marked files in a single file recovery step

Go to the Recover Multiple Files for more information

Memory considerations

R-Linux stores information about found files in computer memory. If there are too many files, R-Linux may
run out of it. To avoid this, you have two options:

Recover all files

If you want to recover data from an entire file system object (a partition, partition image, etc.), you may use
the Recover All Files command from the Drive or context menu. Right click the object in the Drives panel to
access the context menu. A Recover dialog box will appear. Select required restore settings, including file
mask. This command restores unlimited number of files without memory restrictions.

View file information in steps

As soon as R-Linux nearly runs out of memory, a Too many files... message appears. You may temporally
stop file listing and browse through found files. Then you can resume file listing. You also may skip this file
section and continue file listing. 

In all cases, R-Linux keeps information about the entire file structure.

· Find and Mark Multiple Files 
· Recover Multiple Files

2.3.1 Find and Mark Multiple Files

If you need to find and mark many files at once, you may do that in the following ways:

By sorting them by their extensions or creation/modification/accessed time

To sort files by their extensions or creation/modification/accessed time,

* On the Folders/Files panel select the tab

Extensions  to sort the files by their extensions
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Creation
Time

to sort the files by their creation time

Modificatio
n Time

to sort the files by their modification time

Accessed
Time

to sort the files by their accessed time

 Other ways to sort files by their extensions or creation/modification/accessed time

· Select the disk on Drives panel, select Open Drive Files Sorted By on the Drive menu, and select
respective option, 

or
· On the Folders panel, right-click the disk letter and select Show Files Sorted By on the context menu

and select respective option,
or
· On the Folders panel, select Show Files Sorted By on the Drive menu and select respective option.

> R-Linux will show the sorted files in the Folders and Content panels, showing the path to each file:

Folders panel for files sorted by their extensions

Content panel with files/folders sorted by their extensions

To return to the conventional view,

* On the Drives panel, right-click the partition, select Open Drive Files Sorted By on the context
menu, and select Real File System Structure, 

or

On the Folders panel, select Show Files Sorted By on the Drive menu and select Real File System

Structure

By finding and marking multiple files using the Find/Mark dialog box

You may find and mark all the files on the entire disk by using Mark matched files in the Find/Mark mode
option. You may specify all the necessary search options and mark all the found files. Please note that each
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find and mark/unmark operation is independent from previous ones. That is, if a file matches the search
criteria, it will be marked/unmarked regardless of its previous marked/unmarked state.

For example, if you first mark all doc files, and then all txt files, all doc files remain marked, too. If you then
decide to unmark all files smaller than 2 kB, all doc and txt files will stay marked except those that less than
2 kB.

2.3.2 Recover Multiple Files

If R-Linux while recovering files encounters either an already existing file or file with a broken name, normally
it will stop working and ask you what to do with the file. If you recover multiple files, that may require you
answer a lot of the same questions. You may use Mass File Recovery Options on the Recover dialog box to
instruct R-Linux what to do in those cases for all files.

Recover dialog box

 Mass FIle Recovery Options

File Already Exists These options instruct R-Linux what to do if there already exists a file with
the same name.

Prompt If this option is selected, R-Linux asks the user what to do for each such
file. It stops file recovery until it receives the answer.

Add a File ID to filename If this option is selected, R-Linux adds a File ID to the file name. If a file
already exists with the same name and that file ID, a number will be added
to th file name and file ID.

Overwrite If this option is selected, R-Linux overwrites the old file with the new one.

Skip If this option is selected, R-Linux skips all new files with the same name.

Broken File Name These options instruct R-Linux what to do if a file to be recovered appears
to have an invalid name.

Prompt If this option is selected, R-Linux shows the standard Broken File Name

dialog box for each file with a broken file name. It stops file recovery until it
receives the answer.

Rename and change all
invalid symbols to:

If this option is selected, R-Linux changes all invalid characters to the
character specified.

Skip If this option is selected, R-Linux skips all files with broken file names.

Extended options

These options give you more flexible ways to process multiple files with the same name. You may
compare files by time (Modified) and size, and decide what R-Linux should do with those duplicates. If
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any of the files has an invalid time, the comparison by time is skipped. In this case, if comparison by size is
not  active, R-Linux goes to the default action..

Recover (Advanced - Extended options) dialog box

Extended advanced file recovery options

First
compare
time
First
compare
size 

These options instruct R-Linux which condition to use first, file time or size.

Compare
time
Compare
size

These options instruct R-Linux to enable comparison by time and size..

Actions These selectable actions instruct R-Linux what to do if the condition is met.

Empty
field

If this option is selected, R-Linux skips the condition.

Prompt If this option is selected, R-Linux asks the user what to do for each such file. It stops file
recovery until it receives the answer.

Rename If this option is selected, R-Linux adds a File ID to the file name. If a file already exists
with the same name and that file ID, a number will be added to th file name and file ID.

Skip If this option is selected, R-Linux skips all new files with the same name.

Overwrite If this option is selected, R-Linux overwrites the existing file with the new one.

Time
conditions

If the Modified time stamp is invalid, R-Linux will skip the comparison.

Equal time Two time stamps are the same.

Older The existing file is older than the new one.i

Newer The existing file is newer than the new one.i

Size
conditions

Equal size Two files have the same size.

Smaller The existing file is smaller than the new one.i

Bigger The existing file is bigger than the new one.i
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By default The action R-Linux takes when none of the comparison conditions have been met. That
may happen when the comparison by size is not enabled. 

2.4 Various Disk and Volume Managers
R-Linux can work with objects created by various Linux disk and volume managers. Currently, the following
managers are supported:

· Linux mdadm RAIDs

· Logical Volume Manager (LVM and LVM2)

R-Linux can automatically recognize and add their physical components, component images, or the user can
manually add the components when their data is damaged so severely that R-Linux cannot recognize them.

2.4.1 Linux mdadm RAIDs

mdadm is a Linux utility used to manage and monitor software RAID devices.

R-Linux supports such devices and when drives from a mdadm RAID are connected to a Linux computer, it
automatically detects them and assembles mdadm RAIDs accordingly. 

Linux mdadm RAIDs

R-Linux detects components from mdadm RAIDs and creates those RAIDs automatically. At the same time,
R-Linux gives access to the components of those RAIDs (hard drives and images).

mdadm RAIDs in R-Linux

When an automatically created mdadm RAID is selected, R-Linux highlights its components. It also highlights
the mdadm RAID that Linux may itself create from the same components. 

R-Linux shows broken mdadm RAIDs in pink. 

https://en.wikipedia.org/wiki/Mdadm
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Broken mdamd RAIDs in R-Linux

2.4.2 Linux LVM/LVM2

Linux LVM is a logical volume manager for the Linux OS that manages disk drives and other data storage
devices. Using it, It is possible to create single logical volumes on several physical disks, add and replace them
in a running system, resize logical volumes, create various RAID configuration, and so on. You may read more
about Linux LVM on this Wikipedia article: Logical Volume Manager (Linux).

LVM volume example

R-Linux automatically detects disks from LVMs and creates their virtual volumes automatically. At the same
time, R-Linux gives access to the components of the virtual LVM volumes (hard drives and images).

LVM Volumes in R-Linux

When an automatically created LVM volume is selected, R-Linux highlights its components. It also highlights
the LVM volume that Linux may itself create from the same components.

R-Linux shows broken virtual LVM volumes in pink. Broken LVM volumes in R-Linux

http://en.wikipedia.org/wiki/Logical_Volume_Manager_%28Linux%29
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III Text/Hexadecimal Viewer

Any object visible by R-Linux can be viewed in the Text/Hexadecimal Viewer. It is also able to parse the
data and represent data according to various data patterns.

· Viewing Objects 

· Navigating through an Object

· Data Copy

· Files and Sectors

R-Studio Features
Contact Information and Technical Support
Data Recovery Using R-Linux
Basic File Recovery
Advanced Data Recovery
Mass File Recovery
Technical Information and Troubleshooting



Text/Hexadecimal Viewer 61

© 2025 R-Tools Technology Inc.

3.1 Viewing Objects

To view an object,

1 Right-click the object and select View on the context menu

 Other ways to view the object

· Select the object and select View on the File menu
or
· Select the object and press the Ctrl+E keys

> A Viewer  panel will appear

 R-Linux Text/Hexadecimal viewer
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Data Parsed According to the Selected
Pattern

Object Properties

Object Sector Mapping Data Shown as Various Digits
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Binary view

Text view

Find Results

List of Bookmarks

Text/Hexadecimal Viewer status
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Previous Pattern

Click this button to go to the previous
pattern.

Next Pattern

Click this button to go to the next
pattern.

Save Changes

Click this button to save changes.

Code pages

Turns supported code pages on/off.

Autoflow

Click this button to turn autoflow on.

Panel view options
You may set which panels and bars to enable/disable.

 To enable/disable:

ANSI data Select/clear ANSI on the View menu

OEM data Select/clear OEMr on the View menu

UNICODE data Select/clear UNICODE on the View menu

UNICODE+ data Select/clear UNICODE+ on the View menu

Toolbar Select/clear Toolbar on the View menu

Properties View Select/clear Properties View on the View menu

Sectors View Select/clear Sectors View on the View menu

Data Interpreter
View

Select/clear Data Interpreter View on the View menu

Template View Select/clear Template View on the View menu

Bookmarks View Select/clear Bookmarks View on the View menu

Find Results View Select/clear Find Results View on the View menu

2 View the information

Viewing

You may view data in 4 various code pages: ANSI/OEM/UNICODE/UNICODE+ by switching on/off
the respective code pages in the Code pages buttons or select the appropriate code pages on the View

menu.

Patterns or Templates

You may select a pattern according to which the data will be parsed and shown in the parsed data pane.
The Data Interpreter shows the data selected on the Template pane in various representations.

You may find the next or previous data that matches the pattern signature on the disk. Right-click the right
pane of the viewer and select either Find Template Signature Next or Find Template Signature

Previous on the context menu. You may also select these items on the Edit menu.
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Navigating.
Text/hexadecimal viewer gives you various ways to navigate into an object. See the Navigating
through an Object for more details.

Data Copy

Text/hexadecimal viewer gives you various ways to copy selected data navigate in an object. See the
Data Copy for more details.

Selecting and saving an area in the Viewer

You may select an area in the Viewer panel and save it as a file. 

To select and save an area in the Viewer panel,

1 Right-click the beginning of the selection and select Select From on the context menu

2 Right-click the end of the selection and select Select To on the context menu

 Other ways to select an area

·  Select Select... on the Tools menu and specify an area to select on the Select dialog box,
or
· Click the start point of the area and drag the mouse cursor to its end.

If you need to select an entire object, select Select All on the Tools menu or click the Ctrl+A key

Select dialog box

3 Select an appropriate item in the Tools menu to save the data in a required format and specify its
file name

Select: 
Save to Binary File... to save the data in the binary format (default extension is .bin)
Save to Hexadecimal
File

to save the data in the binary format (default extension is .hex)

on the Tools menu.

If you select an existing file, R-Linux will ask you if you want to append or overwrite the file.

> Viewer will save the data to the file

3.2 Navigating through an Object

Navigating

You may quickly move to a particular part of the object. To move to a particular part of the object being
viewed/edited, enter the required offset in the Go to Offset field between the buttons.

Type an offset to which you want to go. You may select between bytes and sectors. See the Data Formats
and Multipliers topic for more details on data formats.
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You may also use the Go To Offset dialog box to go to a specified place in the object. Click the Offset

field on the Status bar. You may also use this dialog box to copy the offset.

Go To Offset dialog box

 Go To Offset options

From: Jump / offset direction. For example, if you need to find the offset from the object
end for a selected byte, switch to the End (backward) option.

HEX / DEC Switch between the hexadecimal and decimal data representation.

Range Range of values that can be entered.

dec / hex: Alternative data representation. 

Offset: Flat data offset (without separation between the sector and offset in the sector).

Sector / offset Data offset represented as a sector and offset in the sector.

Go! /OK buttons The Go! button moves the cursor to the specified positions, but the Go To Offset

dialog box remains open. The OK button closes the dialog box after moving the
cursor. 

Searching

To search for a particular string, click the Find, Find Next, or Find Previous buttons or the same items on
the Edit menu, and specify the string on the Search dialog box.

Search dialog box

 Search options

Not Equal Search for the place which content is not equal to the string. For
example, the first byte not equal to 00 or FF.

Search for
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HEX Field for the string to search for in the hexadecimal
representation

ANSI Field for the string to search for in the ANSI encoding

OEM Field for the string to search for in the OEM encoding

UNICODE Field for the string to search for in the UNICODE encoding

Match case Select this check box to make the search case-sensitive

Search area

From current position Select this check box to start search from the current position

From start position Select this check box to start search from the beginning of the
object

From Address Select this check box and specify the range in which the
search is to be carried out

Search position

Exhaustive search Select this check box to search the entire object

Search at offset Select this check box and specify the sector offset from which
the search will start

Reverse Select this check box to start the search in the reverse
direction

Find all Select this check box to search for all instances of the string to
search. Search results will be shown in the Find Results pane.

Text/Hexadecimal Viewer will show the search progress.

Search results are shown on the Find Results pane. You may easily move to the required found item by
clicking the item.

Features of the Not Equal option

Suppose we have an object which first 3 consecutive sectors start with:
Sector1   FILEAAAAA..............................................
Sector2   FILEBBBBB..............................................
Sector3   NOTAFILE...............................................

And the search string is Not Equal FILE.
If the Exhaustive search option is selected, the Text/Hexadecimal Viewer will stop at the first A
character in Sector1.
If the Search at offset=0 option is selected, the Text/Hexadecimal Viewer will stop at the N character
in Sector3.

Bookmarking

You may create bookmarks to easily move to those places. Right-click the cursor on the place you want
to bookmark and select Toggle Bookmark on the shortcut menu. The list of bookmarks appears in the
Bookmark pane. You may easily move to the required bookmark by clicking it in the list.

You may control bookmarks on the Edit menu.
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3.3 Data Copy
Text/hexadecimal Viewer gives you various ways to copy selected data in an object. 

Data selected in Text/hexadecimal viewer

Depending on what column you have control-clicked, the following commands are available in the context
menu:

When right-clicking any column
Copy Editor Display

Data pasted into a text editor

When right-clicking any column
Copy as File Signature

Data pasted into a text editor

When right-clicking the Binary data
column
Copy as "Binary data"

Data pasted into a text editor

When right-clicking the ANSI
column
Copy as "ANSI"

Data pasted into a text editor
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When rightl-clicking the UNICODE
column
Copy as "UNICODE"

Data pasted into a text editor

3.4 Files and Sectors
You may see which file is written on a particular sector. To do so:

1 Enumerate files on a logical disk on the Drives panel.

2 Go to the tab of that logical disk and select Show Files in HexViewer on the Files menu.

3 Return to the Drives panel and select View on the shortcut menu. 

> R-Linux will show a file that belongs to a particular section.

File in a sector
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IV Technical Information and Troubleshooting

This chapter covers various technical issues and troubleshooting.

· IntelligentScan technology

· Data Recovery Issues

· Data Formats and Multipliers

· Bad Sectors

· Memory Usage

· R-Linux Switches

· Properties Tab

R-Studio Features
Contact Information and Technical Support
Data Recovery Using R-Linux
Basic File Recovery
Advanced Data Recovery
Mass File Recovery
Text/Hexadecimal Viewer

4.1 IntelligentScan Technology
R-Studio uses a unique IntelligentScan technology when it tries to recover the data on the area being
scanned. 

While scanning the selected area, R-Studio reads data directly from the disk, analyzes them, and tries to
determine a record to which the data belong. The following record types are possible:

· MBR/GPT records
· NTFS Boot Sector, Folder, and MFT records
· FAT/exFAT Boot Sector, folder, and file records
· ReFS Boot sector records and ReFS Meta blocks
· HFS/HFS+ Volume headers and BTree+ nodes
· APFS Super blocks, APFS Volume blocks, and APFS nodes
· Ext2/3/4FS SuperBlocks records
· UFS/FFS SuperBlock records
· Specific file signatures of Known File types for raw file carving

All these record types have different, but known, structure. Knowing valid values of record fields and relations
between them for each record type, R-Studio determines a record type for the data. If such record type
cannot be unambiguously determined, the data are assigned to the most probable record type. The same data
can be assigned to several record types, with a certain probability for each assignment. A list of possible files
is generated from these records.

R-Studio generates a record list for each record type. This list contains references to records assigned to a
record type from the list with their assignment probability. The same data can be included into different record
lists. Then R-Studio analyzes relations between elements in each list and between different lists, and generates
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a list of found partitions with their parameters, such as partition start point and probable size, file system type,
cluster size, and existence probability.

Using the file list and partition list, R-Studio reconstructs file systems and files on the found partitions. One file
can be attributed to several different partitions.

When the entire disk or its part has been scanned, R-Studio shows all found partitions. Then the parameters
of the found partitions may be manually corrected, if additional information on them is available. 

Using the IntelligentScan technology, R-Studio can recover files not only on new and existing partitions. It
also can find and recover data on partitions that have been deleted or reformatted. If, for example, there was
an NTFS partition, which later was reformatted as a FAT partition, R-Studio will show two partitions on the
same place on the disk, one having the FAT file system, the other the NTFS. Then, found files can be
recovered.

The IntelligentScan technology makes R-Studio a very powerful data recovery tool, but it is not
omnipotent. As it uses probabilistic approach to data reconstruction, it cannot guarantee 100% correct
results. Moreover, even if R-Studio has reconstructed data structure correctly, it is impossible to guarantee
that all found files will be completely and correctly recovered, as new data may be already written over the
old files.

4.2 Data Recovery Issues

Files:

Hard links 

Hard links are file system entries that give file names to files. This term is usually used when files may have
several names. R-Studio shows hard links using the following icons:

A hard link: 

The target file: 

You may find a target or hard link for a file. Right-click the file and select Links on the context menu.

4.3 Data Formats and Multipliers
You may enter data in all numerical fields either in sectors or in bytes. If there is no letters are after the
number, R-Linux assumes the numbers are in bytes.

Decimal numbers are entered as they are: 2372354

Hexadecimal numbers are entered as 0x23Fa67 or 23Fa67 hex.

The following case-insensitive notation is possible:
b 1 byte
kb 1 kb = 2^10=1024 bytes
mb 1 mb = 2^20=104857 bytes
gb 1 gb = 2^30=1073741824 bytes
tb 1 tb = 2^40=1099511627776 bytes
eb 1 eb = 2^50=1125899906842624 bytes
hex A hexadecimal number
sec (sector) A number is in sectors

You may also slect the multipliers in the drop-down boxes. 

https://en.wikipedia.org/wiki/Hard_link
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Type an offset to which you want to go. You may select between bytes and sectors. See the Data Formats
and Multipliers topic for more details on data formats.

When the multiplier has been changed, the data value will be changed according to the specific context
commands for that field:

Suppose, the initial value is 1 GB, and the sector size of the object is 512 byte. The results will be the
following:

Command: No recalculate

Change from GB to MB: 1

Change from GB to Sectors: 1

Command: Always recalculate

Change from GB to MB: 1024

Change from GB to Sectors: 2097152

Command: Units type recalculate

Change from GB to MB: 1

Change from GB to Sectors: 2097152

4.4 Bad Sectors
Quite often, drives from which the data are to be recovered have bad sectors, or those sectors that are very
hard, even impossible, to read, mostly due to hardware problems. R-Linux tries to read such sectors several
times. The number of tries is specified either on the Settings/?Bad Sectors dialog box, or on the Properties

tab, the Drive Control section, for each drive separately. 

When R-Linux encounters such bad sectors while performing various tasks and they appear unreadable, it
treats them as follows:

Object images:

R-Linux fills the space in the image file where the bad sectors should be with the pattern specified in the
Pattern to fill bad blocks field on the Settings/?Bad Sectors dialog box. Please note that R-Linux writes the
pattern on the image, not on the source drive. 

Files

If Skip files with bad sectors on the Recovery dialog box is cleared, R-Linux fills bad sectors in the recovered
file with the pattern specified on the the Settings/?Bad Sectors dialog box. Information about such files will
appear in the Log.

If Skip files with bad sectors on the Recovery dialog box is selected, R-Linux skips files with bad sectors and
displays their list on the Files with bad sectors dialog box when the recovery has been completed. You may
select files to immediately recover them or to mark for later recovery. You may also save this list to a text file.
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Files with bad sectors dialog box

Files with bad sectors Buttons

Select All Click this button to select all files in the list.

Clear All Click this button to unselect all selected files.

Mark Click this button to mark all selected files in the list. 

Save to File Click this button to save the list of files with bad sectors to a text file. 

Recover Click this button to immediately recover selected files. The bad sectors in the
recovered files will be filled with the pattern specified in the Pattern to fill bad

blocks field on the Settings/?Bad Sectors dialog box.

Objects edited in the Text/?hexadecimal Viewer

Bad sectors in the objects viewed in the Text/?hexadecimal Viewer are shown as filled with the pattern
specified in the Pattern to fill bad blocks field on the Settings/?Bad Sectors dialog box.

4.5 Memory Usage
You may see how much memory R-Linux uses while performing a data recovery task. This is especially
useful when scanning large disks on a computer with limited resources.

To view memory usage,

1 Select Memory usage on the Tools menu

> R-Linux will show the total memory in your computer and how much memory it uses

Memory usage dialog box

 Memory usage

Process Memory Shows how much memory R-Linux uses. Limit shows how much memory your
system can virtually allocate to R-Linux. Actual memory allocation depends also
on the RAM and swap file sizes.

System Memory
Physical

Shows how much RAM is in your system

System Memory
Swap

Shows how much virtual memory is in your system
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4.6 R-Linux Switches
If there are problems in starting R-Linux and while working with it, you may use switches to avoid them.

The following switches are available:
-all_drives Forces R-Linux to show all partitions in the system. Normally R-Linux shows

only local disks in the system. Some storage devices may pretend that they are not
local disks.

-debug Includes additional debug information. When this switch is used, an additional
command Create FS Snapshot on the context menu appears for an object with a
file system. An FS Snapshot contains system data for the file system only (file
descriptions without file contents). If a problem appears, this snapshot can be sent
to R-Linux technical support to identify the problem. This switch greatly slows R-

Linux. You may also turn this mode on by selecting Debug Mode on the Tools

menu
-flush Flushes the log file after each write to log operations. This switch is helpful when

R-Linux locks and its log file remains in memory cache unwritten to a disk. This
switch greatly slows R-Linux.

-log <filename> Started with this switch, R-Linux writes its log into the specified file. If R-Linux
locks and its log file remains in memory cache unwritten to a disk, use the -flush
 switch.

-mem <size in MB> Sets memory usage limit in MB for R-Linux to reconstruct the file tree. When it
exceeds the limit, a Too many files... message appears. You may temporally stop
file listing and browse through found files. Then you can resume file listing. You
also may skip this file section and continue file listing. Example: -mem 400 - sets
the limit to 400 MB.

-no_ide_ext Turns off the inquiry about extended information on HDDs in Wind9x/ME. This
switch may be helpful if R-Linux returns information about HDDs incorrectly
(detects HDD geometry incorrectly).

-no_int13 Turns off the disc access through Int13 in Wind9x/ME. This switch may be helpful
if the system operates incorrectly (detects HDD geometry incorrectly or lock the
system).

-no_ios Turns off the Wind9x/ME protected-mode I/O system. This switch may be helpful
if this system operates incorrectly (detects HDD geometry incorrectly or lock the
system).

-reset R-Linux resets an HDD controller each time it reads a bad sector. This switch
may be helpful if the controller locks after it attempts to read a bad sector, or
returns incorrect data.

-safe Disables automatic partition search on a hard drive, file system recognition on
partitions, and other potentially problematic operations. In this mode, it is
necessary to use Find partition command from the hard drive context menu to
manually find a partition.

If an unrecognized problem appears, start R-Linux with the -debug and -log <filename> switches, and
send the log and screenshot of the R-Linux main panel to the R-Linux technical support:
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R-Linux Technical Support Team is available 24 hours a day, seven days a week, and has an average
response time less than 4 hours.

4.7 Properties Tab

Object size units

You may select the units in which the information on object sizes will be displayed.

To select the units

1 Select Properties on the View menu

2 Select the units in which you want to see object sizes.

You may select
Show as Bytes
Show as Sectors
Show as Bytes and Sectors

1.Basic information

This section shows basic information for a disk object.

 More information...

Drive Type Device/disk type and subtype. Current R-Linux version supports the following
types:
Disk, WORM, CDROM, Optical, Changer, Floppy, RAM Disk, LDM Partition, LDM
Component, LDM Volume

and subtypes:
Device, OS File, Physical Drive, Mount Point, Partition, Volume Set, Mirror, Stripe Set,
RAID5

Name Device/disk name

Size Device/disk size

Bus Type Device/disk bus type. Can be:
IDE/ATA, IDE/ATAPI, SCSI, Floppy, USB, 1394, SSA, FibreChannel, RAID, SMART,
ABIOS

2.Information on hard drives and logical disks

This section shows available information on hard drives and logical disks. These properties depend on the
drive/disk type and appear only when applicable. Under Windows NT/2000/XP/2003, an IDE drive/disk
may be represented as a SCSI device, that is why the SCSI Address section appears under these OSes for
those drives/disks.

 More information...

OS object Appears for image files under Windows 9x/ME and NT/2000/XP/2003, for
drives/disks under Windows NT/2000/XP/2003 only. An object name used by OS
to access the device/disk.

R-Studio driver Driver names (both internal and OS) used to access this drive/disk.

Sector Size Drive/disk sector size

Physical Drive
Geometry

This section shows physical geometry for a hard drive. For a logical disk it shows
the physical geometry for a hard drive where the logical disk resides
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Cylinders

Tracks Per Cylinder

Sectors Per Track

Sector Size

Device
Identification

This section shows vendor information for the drive/disk

Vendor

Product

Firmware

Bus

SCSI Address This section shows SCSI information for the drive/disk

Port Number

Path ID

Target ID

Lun

Windows 9x/ME adds the following properties:

Int13 Drive Number 128 for the first hard drive accessible through Int13, 129 for the second one, etc.
0...128 for drives and other devices accessible through a Windows 9x/ME
protected mode driver, if their Int13 device option is disabled. R-Linux can use
Int13 disk access, and for some drive types, like SCSI devices, Int13 access is
preferable. You may consider enabling the Int13 device option in the Windows
Device Manager for such devices.

Int13 Extension
Version

Int13 Extension Version Support for hard drives. Extended Int13 support is
necessary for large drives. If this property is zero, Extended Int13 is not supported,
otherwise, it shows Extended Int13 standard version, the large, the better.

3.Properties controlling access to hard drives and logical disks

This section shows properties that control access (read and write) to hard drives and logical disks. They are
set to their optimal values and should be altered only if access problems appear.

 More information...

Drive Control

Maximum transfer Maximum data size that can be read or written during a single access to the drive. If
there are problems with drive access, decrease the value of this property

I/O Unit Data size read or written during a single access to the drive is a multiple value of this
property. If there are problems with drive access, decrease the value of this
property

Buffer Alignment Drive data transfer buffer is positioned at an address multiple value of this property.
If there are problems with drive access, increase the value of this property.

These three properties are set by OS drivers. If the drivers set incorrect values, problems may appear
during data transfer operations. You can alter them until data transfer becomes stable.
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I/O Tries Number of read/write tries during access to the drive. If there are bad sectors on
the drive, increase the value of this property. This may help to successfully read
those sectors. Sometimes, if the I/O Tries parameter is set too large and there are
some unreadable sectors on the hard drive, the hard drive-controller pair may
refuse to perform any successive read/write operations with the entire hard drive
when it fails to read/write such sectors. In this case, set this parameter to zero.
R-Linux treats bad sectors in the following way:
It reads a certain part of disk (predefined by Windows) and
· If Default read attempts is set to 0, the entire part with bad sectors will be filled

with the specified pattern. 
· If Default read attempts is set to a non-zero value, R-Linux reads again that part

sector by sector, repeating the attempts the specified number of times. If R-
Linux still cannot read a bad sector, it fills the sectors with the specified pattern.
In this case only the bad sectors will be filled with the pattern, but that extremely
slows the disk read process.

For example, if you set Default read attempts to 1, a bad sector will be read 2 times.

4.Partition properties

A partition is a continuous area on a hard drive, characterized by its offset and size. There are partitions on
basic disks, dynamic disks, and recognized volumes and partitions. R-Linux treats regions like partitions.

 More information...

Partition Offset Initial offset for the partition.

Partition Size Size of the partition.

Partition Type File system type for the partition. If the record in the drive partition table is
incorrect, this property may differ from the actual file system type for this partition.
Still, R-Linux will process this partition correctly, as it does not use this property.

Partition number Appears under WinNT/2000/XP/2003 only. Shows the number of the partition on
the physical drive.

For regions and recognized partitions, Partition Offset and Partition Type properties can be manually
corrected.

5.Compound volume properties

A compound volume is a union of several partitions or other disk objects. Each union type has its own
rules, unique for each compound volume type. Among compound volumes are: Volume Sets (RAIDs Level
0), Mirrors (RAIDs Level 1), RAIDs5 (RAIDs Level 5), both physical and created by the user (Virtual
Volume Sets, Virtual Stripe Sets, Virtual Mirrors, Virtual RAID5).

 More information...

Main properties of compound volumes are parents (disk objects from which a compound volume is
created) and their order. These properties may be viewed in the Parents tab.  For user-created
compound volumes these properties may be altered.

Raid Block Size Data block size for compound volumes of RAID (Level 0-5) types
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6.LDM disks and volumes (Dynamic Disks)

LDM disks and volumes are volumes controlled by Logical Disk Manager (LDM). They are represented
on a hard drive as a LDM database rather than partition tables. Under Windows 2000/XP/2003, LDM
disks are also called Dynamic Disks.

 More information...

Offset of Logical
Disk

Initial offset of a logical disk on a hard drive. For disks, initially formatted by LDM,
this value is often 31.5KB, for converted disks, it may be larger.

Supposed Parents
Count

Supposed number of parent partitions for compound LDM volumes. If the LDM
database is not damaged, the value of this property must be equal to the number of
parent objects in the Parents tab for the disk object.

LDM Host GUID Global Unique Identifier of a computer system where this LDM disk group has
been created.

LDM DiskGroup
GUID

Global Unique Identifier of the LDM disk group.

LDM Disk GUID Global Unique Identifier of the hard drive.

LDM Volume GUID Global Unique Identifier of the volume.

LDM Disk ID Local hard drive Identifier, unique within this LDM disk group.

LDM Partition ID Local partition Identifier, unique within this LDM disk group.

LDM Component ID Local component Identifier, unique within this LDM disk group.

LDM Volume ID Local volume Identifier, unique within this LDM disk group.

LDM Disk AltName Additional Alternative Name given by LDM to the hard drive.

LDM Disk DriveHint Last name of the volume, under which is has been mounted in the system. May be
either a letter (C:, D:, etc.), or a mount point under Windows 2000/XP/2003.

7.File System Volume properties

A File System (FS) volume is a disk object where a certain, supported by R-Linux, file system is present.
There are two FS volume types: FS volume on a regular disk object and a recognized volume, found by a
scan process. FS volume properties depend on volume's file system and type.

7.1.NTFS Volume properties

These properties are present for all NTFS volumes and represent their main properties. For recognized
volumes, these values can be altered.

 More information...

NTFS Information Regular volumes

Recognized NTFS Recognized volumes

Cluster Size Cluster size for the NTFS volume.

MFT record size Size of one MFT record describing one file on the NTFS volume. This is an
important property of any NTFS volume. Its common value is 1KB. If this property
has incorrect value, many files may be incorrectly recovered.

Sector Size Sector size for the physical drive. This property is read from the boot sector of the
NTFS volume and does not affect R-Linux operation.
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Index Block Size Index block size for the NTFS volume. This property determines binary trees used
to store NTFS folder structure. It does not affect R-Linux operation.

MFT position MFT offset from the start of the NTFS volume.

MFT Mirror
Position

Second MFT copy offset from the start of the NTFS volume.

Volume size Size of the NTFS volume. This property does not affect R-Linux operation.

7.2.FAT Volume properties

These properties are present for all FAT volumes and represent their main properties. For recognized
volumes, these values can be altered.

 More information... 

FAT Information Regular volumes

Recognized FAT Recognized volumes

FAT Bits (12,16,32) FAT type. 12 for the FAT12, 16 for the FAT16, 32 for the FAT32.

Cluster Size Cluster size for the FAT volume.

First Cluster Offset Offset of the first cluster from the start of the FAT volume.

Boot Directory
Cluster

(For FAT32 only.) Cluster number where the root directory starts on the FAT
volume where the logical disk resides.

Root Directory
Offset

(For FAT12 and 16 only.) Root directory offset from the start of the FAT volume.

Root Directory
Length

(For FAT12 and 16 only.) Root directory length for the FAT volume.

First FAT Offset Offset for the first FAT table on the volume. Together with the Size of One Fat Table

property, is a most important property for a FAT volume. If this property is
incorrect, many files (especially fragmented ones) may be incorrectly recovered.

Size of One FAT
Table

Size of one FAT table on the volume.

Sector Size Sector size of the hard drive. This property is read from the boot sector of the FAT
volume and does not affect R-Linux operation.

Number of FAT
Copies

Number of FAT copies on the FAT volume.

Active FAT copy Active FAT table number for the FAT volume. Can be set to Disabled, Auto, 1, or
2. If it is Disabled, R-Linux processes the volume as there is no FAT table present.
This may be useful if the volume has been reformatted and thus a new FAT table is
created and the old one is deleted. In this case, it is reasonable to recover files from
the previous volume without processing the new and irrelevant FAT table. All files
will be recovered as continuous byte chains beginning from their start cluster.
Unfragmented files will be recovered successfully. If it is 1 or 2, R-Linux uses the
first or second FAT table copy, respectively. If it is Auto, R-Linux uses both FAT
table copies and decides, which FAT table copy should be used for a particular
FAT table sector. This may be useful when both FAT tables are partially damaged. 

Major version FAT version.
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Minor version FAT minor version.

Volume size Size of the volume.

7.3.Ext2/3/4FS Volume properties

These properties are present for all Ext2/3/4FS volumes and represent their main properties. For
recognized volumes, these values can be altered.

 More information...

Ext2/3/4FS
Information

Regular volumes

Recognized
Ext2/3/4FS

Recognized volumes

Block Size Block size of Ext2/3/4FS file system. A block in the Ext2/3/4FS file system is
similar to a cluster in the FAT file system.

First SuperBlock
Offset

Offset of the first SuperBlock from the start of the Ext2/3/4FS volume.

Blocks Per Volume Number of blocks in the Ext2/3/4FS volume.

INodes Per Volume Number of inodes on the Ext2/3/4FS volume. An inode is a record describing
file's size, attributes, position on an Ext2/3/4FS volume - all information about a
file, except its name, which is stored separately. Therefore, the INodes Per
Volume parameter is equal to the maximum number of files on an Ext2/3/4FS
volume.

Creator OS The OS that created this Ext2/3/4FS volume. May be Linux, Hurd, Masix,
FreeBSD, Lites.

Major version Ext2/3/4FS version. Usually 1.

Minor version Ext2/3/4FS minor version. Usually 0.

Last Mount Time Last mount time for this Ext2/3/4FS volume.

Last Write Time Last write time for this Ext2/3/4FS volume.

Last Check Time Last check time for this Ext2/3/4FS volume.

Volume size Size of the volume.

7.4.Recognized Volume properties

These properties are present for all recognized volumes, regardless of their file system type. They estimate
how reliable those volumes are recognized. This is useful for fast search for, and selection of, optimally
recognized volume to recover.

 More information... 

Parsed File Entries Number of files proving that this recognized volume existed. May have any non-
negative values. The main property characterizing the reliability of volume
recognition. The larger it, the higher probability that this recognized volume has file
system properties that have been correctly found.

Parsed Boot
Records

Number of boot records proving that this recognized volume existed. May be 0 or
1. This is the second important property characterizing the reliability of volume
recognition.
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Estimated Size Estimated size of the recognized FS partition/volume. This property shows the most
probable size of the recognized FS partition/volume. Alternatively, Size and Partition

Size are set to the highest possible values in order to recover the maximum number
of files.
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Recover security     17

Restore folder structure     17

Restore from root     17

Skip files with bad sectors     17

Region     47

Region options    

Disk size     47

Size     47

Start     47

Regular expressions     37

R-Linux switches     74

R-Studio features     2

- S -
Scan options    

Disk size     38

File Systems     38

Offset     38

Save to File     38

Scan Areas     38

Size     38

Start     38

Search options    

ANSI     61, 65

Exhaustive search     61, 65

From Address     61, 65

From current position     61, 65

From start position     65

HEX     61, 65

Match case     61, 65

Not Equal     65

OEM     61, 65

Reverse     61, 65

Search at offset     61, 65

UNICODE     61, 65

Searching for a File     26

Settings    

Bad Sectors     11

File Systems settings     11

Known File Types     11

Log     11

Main     11

- T -
Tabs    

Properties     75

Technical Information and Troubleshooting     70

Text/hexadecimal viewer     60

Allocation     61

ANSI/OEM/UNICODE/UNICODE+     61

Direct     61

Save to Hexadecimal File     61

Std     61

Unlimited     61

Tools menu    

Debug Mode     74

File mask     36

Find     26

Find All     26

Find Next     26

Find Previous     26

Goto     61

Mark All     17

Save to Binary File...     61

Save to Hexadecimal File     61

Select All     61

Settings     11

Unmark All     17

- V -
Various Disk and Volume Managers     58

View menu    

ANSI     61

Arrange     17

Bookmarks View     61
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View menu    

Data Interpreter View     61

Details     17

Device View     6

Event Log     6, 17

Files panel     17

Folders panel     17

OEM     61

Parents Tab     6

Properties     6, 75

Properties Tab     6

Properties View     6, 61

Scan Information Tab     6

Sectors View     61

Status bar     6, 17

Template View     61

Toolbar     6, 17, 61

UNICODE     61

UNICODE+     61
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